Sign up now! · Forgot password?
RSS/Atom feed Twitter

Pasted New Layer

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

4 of 4 messages available
Toggle history

Please log in to manage your subscriptions.

Pasted New Layer rob1955 28 Mar 13:20
  Pasted New Layer Shlomi Fish 28 Mar 13:33
   Pasted New Layer rob1955 28 Mar 14:17
    Pasted New Layer rich404 28 Mar 17:55
2020-03-28 13:20:49 UTC (2 months ago)
postings
2
contact
Send private message

Pasted New Layer

I created a png file, so the background is transparent. I then opened another file, a jpg, to paste the png onto it. The problem is, it's in greyscale, when the original is in colour. What's happened, and how do I solve it.

rob1955 (via www.gimpusers.com/forums)
Shlomi Fish
2020-03-28 13:33:06 UTC (2 months ago)

Pasted New Layer

Hi Rob,

On Sat, 28 Mar 2020 14:20:49 +0100 rob1955 wrote:

I created a png file, so the background is transparent. I then opened another file, a jpg, to paste the png onto it. The problem is, it's in greyscale, when the original is in colour. What's happened, and how do I solve it.

1. You should use .xcf for your gimp workflow, and import/export to different formats at the final stages:

https://en.wikipedia.org/wiki/XCF_(file_format)

2. Can you upload / E-mail the problematic files?

Shlomi Fish       https://www.shlomifish.org/
https://ccmixter.org/files/destinazione_altrove/49997 - “Paint The Sky”

If at first you don’t succeed, destroy all evidence that you tried.
    — Unknown

Please reply to list if it's a mailing list post - http://shlom.in/reply .
2020-03-28 14:17:41 UTC (2 months ago)
postings
2
contact
Send private message

Pasted New Layer

Hi Rob,

On Sat, 28 Mar 2020 14:20:49 +0100 rob1955 wrote:
1. You should use .xcf for your gimp workflow, and import/export to different
formats at the final stages:

https://en.wikipedia.org/wiki/XCF_(file_format)

2. Can you upload / E-mail the problematic files?

Thanks, but somehow, it's sorted itself out. I've done it like this before, with no problems, so I don't know what the problem was. Closed Gimp down, and started again, and it was fine. Confused.

rob1955 (via www.gimpusers.com/forums)
2020-03-28 17:55:11 UTC (2 months ago)
postings
544
contact
Send private message

Pasted New Layer

Thanks, but somehow, it's sorted itself out. I've done it like this before, with
no problems, so I don't know what the problem was. Closed Gimp down, and started
again, and it was fine. Confused.

You should still understand how things work.

All depends on the format of the image you paste **into**.

Paste (or open-as-layers is the same) a RGB image into a greyscale image and the pasted in layer takes the properties of the greyscale image.

Often seen in the worst senario, a RGB image added to a limited colour, indexed image and the user wonders why the colours are screwed up.

rich404 (via www.gimpusers.com/forums)