Sign up now! · Forgot password?
RSS/Atom feed Twitter

GIF format, where is it ?

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

9 of 11 messages available
Toggle history

Please log in to manage your subscriptions.

GIF format, where is it ? Dave Selby 16 Mar 09:42
  GIF format, where is it ? Karl Auer 16 Mar 10:30
   GIF format, where is it ? Dave Selby 16 Mar 12:25
    GIF format, where is it ? Karl Auer 16 Mar 19:05
     GIF format, where is it ? Dave Selby 16 Mar 19:55
GIF format, where is it ? Tom Williams 16 Mar 18:02
Pine.LNX.4.44.0303160610310... 07 Oct 20:15
  GIF format, where is it ? Dave Selby 16 Mar 15:34
   GIF format, where is it ? Guillermo S. Romero / Familia Romero 16 Mar 18:03
20030316214525.11f7b40e.nig... 07 Oct 20:15
  GIF format, where is it ? Dave Selby 16 Mar 22:20
Dave Selby
2003-03-16 09:42:57 UTC (over 17 years ago)

GIF format, where is it ?

Im trying to save my image in .GIF format for a web site, I go down file, save as ... I have a very long list of formats ....

GIF does not seem to be there even though my "teach yourself gimp in 24" manual says it can save in this format.

I tried saving as xxx.GIF, it didn't like it !

Does gimp support GIF ?

Second problem, I work on a 800x600 TFT, the save extension options go off the screen. Usualy when this happens I press my "windows" button, left click the mouse and I can move the menu up and down, It don't work with the extension menu ! As a result I can't see the bottom of the extensions menu.

Any Idea how to view it ?

Dave Debian Woody, gimp 1.2

Karl Auer
2003-03-16 10:30:54 UTC (over 17 years ago)

GIF format, where is it ?

Dave Selby wrote:

GIF does not seem to be there even though my "teach yourself gimp in 24" manual says it can save in this format.

Convert to "indexed" format (Image->Mode->Indexed) and try again...

Second problem, I work on a 800x600 TFT, the save extension options go off the screen. Usualy when this happens I press my "windows" button, left click the mouse and I can move the menu up and down, It don't work with the extension menu ! As a result I can't see the bottom of the extensions menu.

Can't help there...

Regards, K.

-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Karl Auer (kauer@biplane.com.au) +41-43-2660706 (h) http://www.biplane.com.au/~kauer/ +41- 1-6327531 (w)

Dave Selby
2003-03-16 12:25:20 UTC (over 17 years ago)

GIF format, where is it ?

On Sunday 16 March 2003 09:30, you wrote:

Dave Selby wrote:

GIF does not seem to be there even though my "teach yourself gimp in 24" manual says it can save in this format.

Convert to "indexed" format (Image->Mode->Indexed) and try again...

OK tried it, saved it as test.GIF, no go, test.gif no go.

I generated a simple image, blank canvas, red circle, indexed it, saved as .GIF, .gif no go

Im concerned because in my determine file type, the part I can see ! I have ...FLI GBR GIH GLCON HRZ...
ie no GIF, not even hazed out ...

The error when I try and save in GIF format is Save failed
/home/web/Desktop/test.GIF: Unknown file type

Any ideas ? Dave

Dave Selby
2003-03-16 15:34:43 UTC (over 17 years ago)

GIF format, where is it ?

On Sunday 16 March 2003 14:11, you wrote:

On Sun, 16 Mar 2003, Dave Selby wrote:

Does gimp support GIF ?

If you are running gimp on windows, you must install the separately available lzw to support gif.

Just a thought.

Ron stanonik@cogsci.ucsd.edu

Im running gimp on Debian Linux 3.0 Woody, But thank you for the tip, I will search my DVD for a driver of some kind and e-mail you back with the results.

Dave

Tom Williams
2003-03-16 18:02:32 UTC (over 17 years ago)

GIF format, where is it ?

Dave Selby wrote:

Im running gimp on Debian Linux 3.0 Woody, But thank you for the tip, I will search my DVD for a driver of some kind and e-mail you back with the results.

Dave

Try installing libungif:

http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml

Good luck!

Peace....

Tom

Guillermo S. Romero / Familia Romero
2003-03-16 18:03:31 UTC (over 17 years ago)

GIF format, where is it ?

davesgimp@yahoo.co.uk (2003-03-16 at 1434.43 +0000):

Does gimp support GIF ?

If you are running gimp on windows, you must install the separately available lzw to support gif.

Im running gimp on Debian Linux 3.0 Woody,

apt-get install gimp-nonfree

GSR

Karl Auer
2003-03-16 19:05:13 UTC (over 17 years ago)

GIF format, where is it ?

Dave Selby wrote:

Convert to "indexed" format (Image->Mode->Indexed) and try again...

OK tried it, saved it as test.GIF, no go, test.gif no go.

I generated a simple image, blank canvas, red circle, indexed it, saved as .GIF, .gif no go

This is what I did to test my answer before I sent it:

Open the Gimp. Create a new image (File->New), accepting defaults. Right-click in image, select File->SaveAs. Note that GIF is greyed out. Cancel. Right-click in image, select Image->Mode->Indexed, accept defaults, OK. Right-click in image, select File->SaveAs. Click on "Determine File Type" button, select GIF, save file accepting defaults.

Worked fine.

If it doesn't work for you, I have no idea what the problem is :-(

Im concerned because in my determine file type, the part I can see ! I have ...FLI GBR GIH GLCON HRZ...
ie no GIF, not even hazed out ...

That's odd. I see it when the image isn't indexed, but greyed out. It's between GBR and GIH, as you'd expect. What version of the GIMP are you using? I dimly recall that GIF isn't wasn't in all of them because of the Unisys idiocy a few years back... but I could be completely mistaken on that. If you built it yourself, it may be a missed compile-time option too, I guess.

Regards, K.

-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Karl Auer (kauer@biplane.com.au) +41-43-2660706 (h) http://www.biplane.com.au/~kauer/ +41- 1-6327531 (w)

Dave Selby
2003-03-16 19:55:08 UTC (over 17 years ago)

GIF format, where is it ?

On Sunday 16 March 2003 18:05, you wrote:

Dave Selby wrote:

Convert to "indexed" format (Image->Mode->Indexed) and try again...

OK tried it, saved it as test.GIF, no go, test.gif no go.

I generated a simple image, blank canvas, red circle, indexed it, saved as .GIF, .gif no go

This is what I did to test my answer before I sent it:

Open the Gimp. Create a new image (File->New), accepting defaults. Right-click in image, select File->SaveAs. Note that GIF is greyed out. Cancel. Right-click in image, select Image->Mode->Indexed, accept defaults, OK. Right-click in image, select File->SaveAs. Click on "Determine File Type" button, select GIF, save file accepting defaults.

Worked fine.

If it doesn't work for you, I have no idea what the problem is :-(

Im concerned because in my determine file type, the part I can see ! I have ...FLI GBR GIH GLCON HRZ...
ie no GIF, not even hazed out ...

That's odd. I see it when the image isn't indexed, but greyed out. It's between GBR and GIH, as you'd expect. What version of the GIMP are you using? I dimly recall that GIF isn't wasn't in all of them because of the Unisys idiocy a few years back... but I could be completely mistaken on that. If you built it yourself, it may be a missed compile-time option too, I guess.

Regards, K.

I haven't loaded it yet but gimp1.2-nonfree has it built in ... It also has a message ! .....

Description: GIF support for the GNU Image Manipulation Program This package includes GIF support for The GNU Image Manipulation Program. These files are not freely available; their use is disallowed by the UNISYS patent on LZW compression. .
Use at your own legal risk.
Enhances: gimp1.2

mmm kind of looks like its illegal to use, wouldn't be bothered but was intending to use it for commercial work .....

Any idea when the patent runs out !

Dave

Dave Selby
2003-03-16 22:20:53 UTC (over 17 years ago)

GIF format, where is it ?

On Sunday 16 March 2003 19:45, you wrote:

On Sun, 16 Mar 2003 18:55:08 +0000

Dave Selby wrote:

On Sunday 16 March 2003 18:05, you wrote:

Dave Selby wrote:

Convert to "indexed" format (Image->Mode->Indexed) and try again...

OK tried it, saved it as test.GIF, no go, test.gif no go.

I generated a simple image, blank canvas, red circle, indexed it, saved as .GIF, .gif no go

This is what I did to test my answer before I sent it:

Open the Gimp. Create a new image (File->New), accepting defaults. Right-click in image, select File->SaveAs. Note that GIF is greyed out. Cancel. Right-click in image, select Image->Mode->Indexed, accept defaults, OK. Right-click in image, select File->SaveAs. Click on "Determine File Type" button, select GIF, save file accepting defaults.

Worked fine.

If it doesn't work for you, I have no idea what the problem is :-(

Im concerned because in my determine file type, the part I can see ! I have ...FLI GBR GIH GLCON HRZ... ie no GIF, not even hazed out ...

That's odd. I see it when the image isn't indexed, but greyed out. It's between GBR and GIH, as you'd expect. What version of the GIMP are you using? I dimly recall that GIF isn't wasn't in all of them because of the Unisys idiocy a few years back... but I could be completely mistaken on that. If you built it yourself, it may be a missed compile-time option too, I guess.

Regards, K.

I haven't loaded it yet but gimp1.2-nonfree has it built in ... It also has a message ! .....

Description: GIF support for the GNU Image Manipulation Program This package includes GIF support for The GNU Image Manipulation Program. These files are not freely available; their use is disallowed by the UNISYS patent on LZW compression. .
Use at your own legal risk.
Enhances: gimp1.2

mmm kind of looks like its illegal to use, wouldn't be bothered but was intending to use it for commercial work .....

Any idea when the patent runs out !

Dave