Sign up now! · Forgot password?
RSS/Atom feed Twitter

LibGimp-CRITICAL **: file gimppixelrgn.c: line 471

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

1 of 1 message available
Toggle history

Please log in to manage your subscriptions.

LibGimp-CRITICAL **: file gimppixelrgn.c: line 471 Brian Millett 11 Sep 21:29
Brian Millett
2002-09-11 21:29:51 UTC (about 18 years ago)

LibGimp-CRITICAL **: file gimppixelrgn.c: line 471

Hello,
My setup:
redhat 7.2, 2.4.19 kernel
gcc version 2.96 20000731 (Red Hat Linux 7.2 2.96-108.7.2) gimp-1.3.8
gimp-print-4.3.4

When I run gimp, all comes up fine, but the gif images are just grey checker board. When I try to load a jpeg, I get the following message:

using MMX: yes gimp: tool-safe-mode init called
gimp: tool_plug_in_path:
/home/bpm/.gimp-1.3/tool-plug-ins:/usr/local/lib/gimp/1.3/tool-plug-ins gimp: tool-safe-mode init done

(jpeg:9380): LibGimp-CRITICAL **: file gimppixelrgn.c: line 471 (gimp_pixel_rgn_set_rect): assertion `y >= 0 && y + height drawable->height' failed

(jpeg:9380): LibGimp-CRITICAL **: file gimppixelrgn.c: line 471 (gimp_pixel_rgn_set_rect): assertion `y >= 0 && y + height drawable->height' failed

Did not have any compiler errors, linker errors, nor installer errors.

By the way, I do have a canon s40 camera. Gimp-1.3.8 can see and load images from the camera, however I get the same CRITICAL error.

Any ideas?

Thanks.