Sign up now! · Forgot password?
RSS/Atom feed Twitter

gimp slowing computer

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

2 of 2 messages available
Toggle history

Please log in to manage your subscriptions.

gimp slowing computer jdavin@cmu.edu 07 Jun 20:10
  gimp slowing computer Guillermo S. Romero / Familia Romero 07 Jun 20:21
jdavin@cmu.edu
2002-06-07 20:10:55 UTC (over 19 years ago)

gimp slowing computer

Hi,

When I run gimp and open a jpg, it hangs/slows my computer severely. It's so bad that it causes music playing from xmms to skip and die, etc. That almost never happens on my computer... even when compiling programs and things. It lasts for about 10 to 20 seconds, usually starting after the image is actually displayed on my screen.

I'm running gimp 1.2.1 on redhat 7.2 with an Athlon 700, 256 mb ram, Nvidia TNT2 graphics card. The images I'm opening are about 300-400 kb I think - they're 1600x1200 images from my digital camera. The computer also hangs badly when I open multiple images at once, and also when I rotate images.

When I boot into windows and use Photoshop, everything works well - I can open 10 images relatively quickly and without hanging the computer. Any idea why gimp is performing so poorly? I don't really want to upgrade to 1.2.3 now because I don't have a broadband connection, and that might not fix the problem.
Do you think it would help if I ran gimp with a lower job priority (or whatever they call that). I forget how to do it, but I could figure it out. But then the images might just open even slower.

Also, in the past I've noticed that after opening a lot of images, gimp eats up a ton of HD space with temp files (it filled up my partition and then started giving errors). That problem hasn't happened to me recently, I've just had the general slowness problem.

-John

Guillermo S. Romero / Familia Romero
2002-06-07 20:21:57 UTC (over 19 years ago)

gimp slowing computer

jdavin@cmu.edu (2002-06-07 at 1410.55 -0400):

When I boot into windows and use Photoshop, everything works well - I can open 10 images relatively quickly and without hanging the computer. Any idea why gimp is performing so poorly? I don't really want to upgrade to 1.2.3 now because I don't have a broadband connection, and that might not fix the problem.
Do you think it would help if I ran gimp with a lower job priority (or whatever they call that). I forget how to do it, but I could figure it out. But then the images might just open even slower.

What is the size of the gimp cache you have (check in preferences / environment)?

GSR