Sign up now! · Forgot password?
RSS/Atom feed Twitter

Compiling gimp 1.2.3 with gtk+-2.0.x

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

3 of 3 messages available
Toggle history

Please log in to manage your subscriptions.

Compiling gimp 1.2.3 with gtk+-2.0.x <email@rjpark.fsnet.co.uk> 03 Apr 13:39
  Compiling gimp 1.2.3 with gtk+-2.0.x Niklas 03 Apr 21:16
Compiling gimp 1.2.3 with gtk+-2.0.x <email@rjpark.fsnet.co.uk> 04 Apr 10:59
<email@rjpark.fsnet.co.uk>
2002-04-03 13:39:11 UTC (over 17 years ago)

Compiling gimp 1.2.3 with gtk+-2.0.x

Is it possible to compile Gimp 1.2.3 with GTK+-2.0.x, or do I have to use one of the latest development versions of the Gimp 1.3.x? I have installed the latest versions of Pango, ATK, PKG-Config, GLib and GTK, but when I try to compile the Gimp the configure script fails because gtk-config is missing. I know that gtk-config is now replaced with pkgconfig which is installed on my system.

Regards

RJ

Niklas
2002-04-03 21:16:41 UTC (over 17 years ago)

Compiling gimp 1.2.3 with gtk+-2.0.x

Hey...

I belive that you can't do the compile with gtk+2.0 because GIMP 1.2.3 is not ported for 2.0 of GTK+ the versions 1.3.x is the ported ones to GTK+2.0.

So you will either need GTK+1.2 for GIMP 1.2.3 or you get the GIMP 1.3.x version but be warned that the 1.3.x is unstable and is in a big development.So don't expect to much of it.

//Niklas

On Wed, 2002-04-03 at 13:39, email@rjpark.fsnet.co.uk wrote:

Is it possible to compile Gimp 1.2.3 with GTK+-2.0.x, or do I have to use one of the latest development versions of the Gimp 1.3.x? I have installed the latest versions of Pango, ATK, PKG-Config, GLib and GTK, but when I try to compile the Gimp the configure script fails because gtk-config is missing. I know that gtk-config is now replaced with pkgconfig which is installed on my system.

Regards

RJ

<email@rjpark.fsnet.co.uk>
2002-04-04 10:59:29 UTC (over 17 years ago)

Compiling gimp 1.2.3 with gtk+-2.0.x

Thanks for your help. I had a feeling that was what I would have to do but I was having trouble finding information about it. The best I had discovered was that if you install GTK+-1.28 and then GTK+-2.0.0 that the Gimp would be able to find gtk-config installed from the earlier version.

From: Niklas
Date: Wed 03/Apr/2002 19:16 GMT
To: email@rjpark.fsnet.co.uk
CC: gimp-user
Subject: Re: [Gimp-user] Compiling gimp 1.2.3 with gtk+-2.0.x

Hey...

I belive that you can't do the compile with gtk+2.0 because GIMP 1.2.3 is not ported for 2.0 of GTK+ the versions 1.3.x is the ported ones to GTK+2.0.

So you will either need GTK+1.2 for GIMP 1.2.3 or you get the GIMP 1.3.x version but be warned that the 1.3.x is unstable and is in a big development.So don't expect to much of it.

//Niklas

On Wed, 2002-04-03 at 13:39, email@rjpark.fsnet.co.uk wrote:

Is it possible to compile Gimp 1.2.3 with GTK+-2.0.x, or do I have to use one of the latest development versions of the Gimp 1.3.x? I have installed the latest versions of Pango, ATK, PKG-Config, GLib and GTK, but when I try to compile the Gimp the configure script fails because gtk-config is missing. I know that gtk-config is now replaced with pkgconfig which is installed on my system.

Regards

RJ