Sign up now! · Forgot password?
RSS/Atom feed Twitter

Gimp 2.10 and Streetwear font (glyphs)

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

10 of 10 messages available
Toggle history

Please log in to manage your subscriptions.

Gimp 2.10 and Streetwear font (glyphs) vincents 11 Mar 08:59
  Gimp 2.10 and Streetwear font (glyphs) Alexandre Prokoudine via gimp-user-list 11 Mar 09:10
   Gimp 2.10 and Streetwear font (glyphs) vincents 11 Mar 11:14
    Gimp 2.10 and Streetwear font (glyphs) Alexandre Prokoudine via gimp-user-list 11 Mar 12:53
     Gimp 2.10 and Streetwear font (glyphs) scott smart via gimp-user-list 11 Mar 14:00
     Gimp 2.10 and Streetwear font (glyphs) vincents 11 Mar 17:20
  Gimp 2.10 and Streetwear font (glyphs) Liam R E Quin 11 Mar 16:22
   Gimp 2.10 and Streetwear font (glyphs) Alexandre Prokoudine via gimp-user-list 11 Mar 20:38
    Gimp 2.10 and Streetwear font (glyphs) vincents 13 Mar 10:16
  Gimp 2.10 and Streetwear font (glyphs) okfontfree via gimp-user-list 31 May 03:49
2020-03-11 08:59:12 UTC (4 months ago)
postings
4
contact
Send private message

Gimp 2.10 and Streetwear font (glyphs)

Hello Everyone

I'm using Gimp 2.10.14 under Ubuntu and I'm trying to use the Streewear font (https://www.dafontfree.io/streetwear-font-free/) for a creation but I can't access some glyphs.

I checked with online tools such https://opentype.js.org and the characters I'm interested in (for example id 264 -> E.ALT) don't have unicode so it's impossible to display them in the text with shift+ctrl+u :(

I need an Illustrator/Photoshop or is it possible with Gimp?

Thanks for your help,

Best regards,

Vincent

vincents (via www.gimpusers.com/forums)
Alexandre Prokoudine via gimp-user-list
2020-03-11 09:10:32 UTC (4 months ago)

Gimp 2.10 and Streetwear font (glyphs)

On Wed, Mar 11, 2020 at 11:59 AM vincents wrote:

Hello Everyone

I'm using Gimp 2.10.14 under Ubuntu and I'm trying to use the Streewear font (https://www.dafontfree.io/streetwear-font-free/) for a creation but I can't access some glyphs.

I checked with online tools such https://opentype.js.org and the characters I'm interested in (for example id 264 -> E.ALT) don't have unicode so it's impossible to display them in the text with shift+ctrl+u :(

I need an Illustrator/Photoshop or is it possible with Gimp?

Hello,

Any half-decent font manager, including free ones, will give you the possibility to open the full map of characters, pick the one you need, then copy/paste it.

Here is Font Manager doing just that:

https://i.imgur.com/DvChS0e.png

http://fontmanager.github.io/

Alex

2020-03-11 11:14:28 UTC (4 months ago)
postings
4
contact
Send private message

Gimp 2.10 and Streetwear font (glyphs)

Hi Alex,

Thank you for your answer !

So I have installer this font manager you talked about but no help, I still cannot see all the glyphs. It seems that I cant see those without unicode.

https://imgur.com/a/geXO5UV

Any idea to go further please ?

Best regards,

Vincent

Hello,

Any half-decent font manager, including free ones, will give you the possibility to open the full map of characters, pick the one you need, then copy/paste it.

Here is Font Manager doing just that:

https://i.imgur.com/DvChS0e.png

http://fontmanager.github.io/

Alex

vincents (via www.gimpusers.com/forums)
Alexandre Prokoudine via gimp-user-list
2020-03-11 12:53:01 UTC (4 months ago)

Gimp 2.10 and Streetwear font (glyphs)

On Wed, Mar 11, 2020 at 2:14 PM vincents wrote:

Hi Alex,

Thank you for your answer !

So I have installer this font manager you talked about but no help, I still cannot see all the glyphs. It seems that I cant see those without unicode.

https://imgur.com/a/geXO5UV

Okay, so I grabbed the file and opened it in FontForge. I'm guessing you are talking about glyphs towards the bottom.

https://i.imgur.com/kWDJqXY.png

They all have '-1' Unicode value. This is so messed up. Basically you have two options:

1. Find software that would access glyphs that don't belong to any Unicode block. I think the only one that did that was Fontmatrix, and it's not in the Ubuntu repository anymore. Maybe in some PPAs.

2. Use FontForge to map the glyphs that you need to real Unicode characters inside known blocks. As a quick hackaround, you could use smth like Latin Extended A or Latin Extended B: https://unicode-table.com/en/blocks/latin-extended-b/.

For that, if my understanding is correct:

1. Use 'Encoding > Compact' to see everything in one window 2. Click to select a glyph you want to remap 3. Use 'Element > Glyph Info..."
4. Set new value using reference in the link above, press OK

When you are done, uncheck 'Compact' encoding option, export the font file, install it instead of the one you already installed.

In fact, there's option 3: annoy the type designer just enough to get this fixed :)

Alex

scott smart via gimp-user-list
2020-03-11 14:00:38 UTC (4 months ago)

Gimp 2.10 and Streetwear font (glyphs)

On 3/11/2020 02:53, Alexandre Prokoudine via gimp-user-list wrote:

On Wed, Mar 11, 2020 at 2:14 PM vincents wrote:

Hi Alex,

Thank you for your answer !

So I have installer this font manager you talked about but no help, I still cannot see all the glyphs. It seems that I cant see those without unicode.

https://imgur.com/a/geXO5UV

Okay, so I grabbed the file and opened it in FontForge. I'm guessing you are talking about glyphs towards the bottom.

https://i.imgur.com/kWDJqXY.png

They all have '-1' Unicode value. This is so messed up. Basically you have two options:

1. Find software that would access glyphs that don't belong to any Unicode block. I think the only one that did that was Fontmatrix, and it's not in the Ubuntu repository anymore. Maybe in some PPAs.

2. Use FontForge to map the glyphs that you need to real Unicode characters inside known blocks. As a quick hackaround, you could use smth like Latin Extended A or Latin Extended B: https://unicode-table.com/en/blocks/latin-extended-b/.

For that, if my understanding is correct:

1. Use 'Encoding > Compact' to see everything in one window 2. Click to select a glyph you want to remap 3. Use 'Element > Glyph Info..."
4. Set new value using reference in the link above, press OK

When you are done, uncheck 'Compact' encoding option, export the font file, install it instead of the one you already installed.

In fact, there's option 3: annoy the type designer just enough to get this fixed :)

Alex

Just a user here, but I assume GIMP only accesses the Unicode CMAP for a ttf/otf font.  For freeware Font Forge is probably your best bet to get at the full glyph index.  There's some better payware for Win or Mac, no idea about Linux distros.

scott s.

.

Liam R E Quin
2020-03-11 16:22:32 UTC (4 months ago)

Gimp 2.10 and Streetwear font (glyphs)

On Wed, 2020-03-11 at 09:59 +0100, vincents wrote:

I'm using Gimp 2.10.14 under Ubuntu and I'm trying to use the Streewear font
(https://www.dafontfree.io/streetwear-font-free/) for a creation but I can't access some glyphs.

GIMP does not have a glyphs palette i’m afraid, and also it can only use glyphs that are mapped to characters. The Streetware font has access to the glphs at the end via the OpenType alternate glyphs mechanism, but GIMP doesn't support OpenType features and alternates.

slave liam

Liam Quin - web slave for https://www.fromoldbooks.org/
with fabulous vintage art and fascinating texts to read.
Click here to have the slave beaten.
2020-03-11 17:20:53 UTC (4 months ago)
postings
4
contact
Send private message

Gimp 2.10 and Streetwear font (glyphs)

Hi Alex,

Thanks for your test !

I have installed Fontforge, loaded the font, mapped some glyphs (yes those at the bottom) with Latin Extended B using "Glyph info", generate the fonts (Truetype .ttf), but no help. If I use shift+ctrl+u, I still see the Latin Extended B characters ...

Did you manage to do it on your side ?

Thanks !

Vincent

Okay, so I grabbed the file and opened it in FontForge. I'm guessing you are talking about glyphs towards the bottom.

https://i.imgur.com/kWDJqXY.png

They all have '-1' Unicode value. This is so messed up. Basically you have two options:

1. Find software that would access glyphs that don't belong to any Unicode block. I think the only one that did that was Fontmatrix, and it's not in the Ubuntu repository anymore. Maybe in some PPAs.

2. Use FontForge to map the glyphs that you need to real Unicode characters inside known blocks. As a quick hackaround, you could use smth like Latin Extended A or Latin Extended B: https://unicode-table.com/en/blocks/latin-extended-b/.

For that, if my understanding is correct:

1. Use 'Encoding > Compact' to see everything in one window 2. Click to select a glyph you want to remap 3. Use 'Element > Glyph Info..."
4. Set new value using reference in the link above, press OK

When you are done, uncheck 'Compact' encoding option, export the font file, install it instead of the one you already installed.

In fact, there's option 3: annoy the type designer just enough to get this fixed :)

Alex

vincents (via www.gimpusers.com/forums)
Alexandre Prokoudine via gimp-user-list
2020-03-11 20:38:04 UTC (4 months ago)

Gimp 2.10 and Streetwear font (glyphs)

On Wed, Mar 11, 2020 at 7:22 PM Liam R E Quin wrote:

On Wed, 2020-03-11 at 09:59 +0100, vincents wrote:

I'm using Gimp 2.10.14 under Ubuntu and I'm trying to use the Streewear font
(https://www.dafontfree.io/streetwear-font-free/) for a creation but I can't access some glyphs.

GIMP does not have a glyphs palette i’m afraid, and also it can only use glyphs that are mapped to characters. The Streetware font has access to the glphs at the end via the OpenType alternate glyphs mechanism, but GIMP doesn't support OpenType features and alternates.

Oh, I'll be damned, you are completely right, and I messed up. They are referenced via the aalt table. Yes, not much we can do in GIMP right now.

Alex

2020-03-13 10:16:54 UTC (4 months ago)
postings
4
contact
Send private message

Gimp 2.10 and Streetwear font (glyphs)

Hi All !

Thanks guys for your answers.

I will move to Photoshop/Illustrator for this time :( :( :(

Regards,

Vincent

vincents (via www.gimpusers.com/forums)
okfontfree via gimp-user-list
2020-05-31 03:49:34 UTC (about 1 month ago)

Gimp 2.10 and Streetwear font (glyphs)

I'm using Gimp 2.10.14 under Ubuntu and I'm trying to use the Nexa font ( https://fontsio.com/nexa-font-free/ ) for creation but I can't
access some glyphs too.

--
Sent from: http://gimp.1065349.n5.nabble.com/Users-f3.html