Sign up now! · Forgot password?
RSS/Atom feed Twitter

cant move selection under layer

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

6 of 6 messages available
Toggle history

Please log in to manage your subscriptions.

cant move selection under layer tjohansen 10 Feb 21:45
  cant move selection under layer rich404 11 Feb 10:30
   cant move selection under layer rich404 11 Feb 11:49
    cant move selection under layer tjohansen 11 Feb 20:22
     cant move selection under layer Ofnuts 12 Feb 10:25
     cant move selection under layer rich404 12 Feb 17:23
2020-02-10 21:45:55 UTC (8 months ago)
postings
4
contact
Send private message

cant move selection under layer

dont know what I have activated.....

but I have a semi transparent wireframe layer ontop of other layers.

normally I select a region in a underlying layers, cut it at paste it, then I can move it around.

But now I cant as long as there is a visible layer ontop. now when I cut and paste it, I cant move afterwards.

If I hide the layer in top I can move the selection..... Why??? and how to change it back.

tjohansen (via www.gimpusers.com/forums)
2020-02-11 10:30:05 UTC (8 months ago)
postings
576
contact
Send private message

cant move selection under layer

dont know what I have activated.....

but I have a semi transparent wireframe layer ontop of other layers.

normally I select a region in a underlying layers, cut it at paste it, then I
can move it around.

But now I cant as long as there is a visible layer ontop. now when I cut and paste it, I cant move afterwards.

If I hide the layer in top I can move the selection..... Why??? and how to change it back.

Reported as a bug but no obvious action to fix. https://gitlab.gnome.org/GNOME/gimp/issues/4215

You already have one fix. Turn 'semi-transparent-template' layer visibility off.

Other ways. Use the keyboard arrows - (shift + arrow is larger move) Snag, easy to anchor the float by mistake.

Use the move tool with "move the active layer" enabled

Promote the floating layer to a new layer and move.

If possible remove the background from the "semi transparent wireframe" layer so it is a true lines-on-transparency. Then it works as before.

rich404 (via www.gimpusers.com/forums)
2020-02-11 11:49:16 UTC (8 months ago)
postings
576
contact
Send private message

cant move selection under layer

If possible remove the background from the "semi transparent wireframe" layer so
it is a true lines-on-transparency. Then it works as before.

A few try-outs, same as above and all depends on that "semi-transparent-wireframe" template.

Add a layer mask to it as Greyscale copy of layer Then probably colour invert the layer mask.

No need for reduced opacity on template layer. At least that is non-destructive to the template.

Once set up should allow your workflow as with Gimp 2.18

rich404 (via www.gimpusers.com/forums)
2020-02-11 20:22:49 UTC (8 months ago)
postings
4
contact
Send private message

cant move selection under layer

I can see its a bug.

When triyng with a new image with a layer on top, it works fine.

Then trying with an existing image with 20 layers it fails. Maybe its because it was made in 2.8?

tjohansen (via www.gimpusers.com/forums)
Ofnuts
2020-02-12 10:25:37 UTC (8 months ago)

cant move selection under layer

On 2/11/20 9:22 PM, tjohansen wrote:

I can see its a bug.

When triyng with a new image with a layer on top, it works fine.

Then trying with an existing image with 20 layers it fails. Maybe its because it was made in 2.8?

The "problem" is how the Move tool works. By default is picks the topmost layer which isn't completely transparent where you click. This cannot be used when one of your top layers spans the whole canvas and is not completely transparent anywhere, but is otherwise very convenient in most uses of the Move tool.

The other behavior is to move the active layer. You can then select the layer to move in the layers list. You can temporarily switch to that mode by depressing the shift key when you click, or set it permanently in the Move tool options.

2020-02-12 17:23:11 UTC (8 months ago)
postings
576
contact
Send private message

cant move selection under layer

I can see its a bug.

When triyng with a new image with a layer on top, it works fine.

Then trying with an existing image with 20 layers it fails. Maybe its because it was made in 2.8?

Unlikely the problem comes from a Gimp 2.8 image.

It would help if you gave details of the overlay, the semi-transparent top layer template.

A demo using a simple template and a layer mask, maybe you can apply to your images, or not as the case may be.

Only a minute and a half so no epic. https://youtu.be/GtLml4zz1-k

rich404 (via www.gimpusers.com/forums)