Sign up now! · Forgot password?
RSS/Atom feed Twitter

Smudge tool changed!

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

5 of 5 messages available
Toggle history

Please log in to manage your subscriptions.

Smudge tool changed! Sharzi 25 Jan 19:48
  Smudge tool changed! rich404 25 Jan 20:11
  Smudge tool changed! Sharzi 25 Jan 20:16
   Smudge tool changed! rich404 26 Jan 08:44
    Smudge tool changed! rich404 26 Jan 09:15
2020-01-25 19:48:59 UTC (8 months ago)
postings
2
contact
Send private message

Smudge tool changed!

I used to have a round circle smudge cursor (I think that's what it is) and suddenly it's change into an oblong shape that doesn't move the color, but instead seems to break it apart and cast broken lines instead of a hard line.

The pic on the left, you'll see that sometimes it's oblong. The middle one shows how it looks at other times. The one on the right, shows it doesn't smudge in solid form.

You'll also see on the right of the 4th screen shot, about the tool there are a lot of small square icons on the top... that was me clicking on things to try and figure out what happened or how to change it back. As you can see, I am not very savvy about gimp.

Can you help?

Attachments: * https://www.gimpusers.com/system/attachments/1349/original/gimp-smudge.jpg * https://www.gimpusers.com/system/attachments/1350/original/gimp-smudge2.jpg

Sharzi (via www.gimpusers.com/forums)
2020-01-25 20:11:36 UTC (8 months ago)
postings
576
contact
Send private message

Smudge tool changed!

I used to have a round circle smudge cursor (I think that's what it is) and
suddenly it's change into an oblong shape that doesn't move the color, but
instead seems to break it apart and cast broken lines instead of a hard line.

The pic on the left, you'll see that sometimes it's oblong. The middle one shows
how it looks at other times. The one on the right, shows it doesn't smudge in
solid form.

You'll also see on the right of the 4th screen shot, about the tool there are a
lot of small square icons on the top... that was me clicking on things to try
and figure out what happened or how to change it back. As you can see, I am not
very savvy about gimp.

Can you help?

The obvious is the dynamics mode set to 'confetti' - that will account for the brush shapes. Set it to dynamics off.

The big difference between 2.8 / 2.10 is the flow setting. Value = 0 and the smudge tool acts like Gimp 2.8

Set the value greater than zero and the smudge tool acts like a painting / blending brush.

Attachments:
* https://www.gimpusers.com/system/attachments/1351/original/dynamics-off.jpg

rich404 (via www.gimpusers.com/forums)
2020-01-25 20:16:45 UTC (8 months ago)
postings
2
contact
Send private message

Smudge tool changed!

Thank you so much Rich. If you look at the picture of the tool itself, I'm looking toward the top right under where it says "smudge"... there is a dropdown for "mode" but when I click to drop it down, it doesn't. Suggestions?

I used to have a round circle smudge cursor (I think that's what it is) and
suddenly it's change into an oblong shape that doesn't move the color, but
instead seems to break it apart and cast broken lines instead of a hard line.

The pic on the left, you'll see that sometimes it's oblong. The middle one shows
how it looks at other times. The one on the right, shows it doesn't smudge in
solid form.

You'll also see on the right of the 4th screen shot, about the tool there are a
lot of small square icons on the top... that was me clicking on things to try
and figure out what happened or how to change it back. As you can see, I am not
very savvy about gimp.

Can you help?

Attachments: *
https://www.gimpusers.com/system/attachments/1349/original/gimp-smudge.jpg *
https://www.gimpusers.com/system/attachments/1350/original/gimp-smudge2.jpg

Sharzi (via www.gimpusers.com/forums)
2020-01-26 08:44:18 UTC (8 months ago)
postings
576
contact
Send private message

Smudge tool changed!

Thank you so much Rich. If you look at the picture of the tool itself, I'm
looking toward the top right under where it says "smudge"... there is a dropdown
for "mode" but when I click to drop it down, it doesn't. Suggestions?

There are no options for the brush mode when using the smudge tool (the same for the eraser tool)

The mode I was referring to is the **dynamics** mode see (1) in the screenshot.

The Gimp docs are worth reading https://docs.gimp.org/2.10/en/gimp-tool-smudge.html

rich404 (via www.gimpusers.com/forums)
2020-01-26 09:15:28 UTC (8 months ago)
postings
576
contact
Send private message

Smudge tool changed!

There are no options for the brush mode when using the smudge tool (the same for
the eraser tool)

The mode I was referring to is the **dynamics** mode see (1) in the screenshot.

The Gimp docs are worth reading https://docs.gimp.org/2.10/en/gimp-tool-smudge.html

A bit more:

If you still have problem. As a beginner, be aware that when you close Gimp down, the current tool and tool parameters are saved for when you next use Gimp. This might / might-not be a good idea for a beginner who is learning tool functions by experimenting with various settings. Nothing wrong with that, good to experiment.

To reset back to default values, as you get when Gimp is installed;

Use Edit menu -> Preferences In the Preferences dialogue select Tool Options and near the top is "Reset Saved Tool Options to Default Values"

Click on that, click on OK (bottom of the dialogue) close Gimp and restart Gimp for the settings to revert.

As this screenshot: https://i.imgur.com/V9xr5NQ.jpg

rich404 (via www.gimpusers.com/forums)