Sign up now! · Forgot password?
RSS/Atom feed Twitter

Gimp Brush - No Hardedge - Solution

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

2 of 2 messages available
Toggle history

Please log in to manage your subscriptions.

Gimp Brush - No Hardedge - Solution GimpCrazy 27 Sep 03:40
  Gimp Brush - No Hardedge - Solution Ofnuts 27 Sep 07:55
2019-09-27 03:40:45 UTC (3 months ago)
postings
2
contact
Send private message

Gimp Brush - No Hardedge - Solution

Hi folks

Just thought I would share the solution to a long term problem I have been having with Gimp brushes since 2.10.

The problem: I select an object and attempt to paint it but the brush wont do a non feathered edge.

This is a problem with the settings on the selection tool not the brush.

To test: open another blank template and try out your brush on that. If it is anti-aliasing (tiny little blocks on the end) or very choppy looking blocks then the problem is the selection tool settings.

Fix: Re-select whatever it is you want to re-paint. Go to the tool settings and simply unselect the "anti-aliasing" selection. Instant hard edge. Duh. Easy once you know how.

I think it is possible that later versions of Gimp have the box checked as a default.

GimpCrazy (via www.gimpusers.com/forums)
Ofnuts
2019-09-27 07:55:37 UTC (2 months ago)

Gimp Brush - No Hardedge - Solution

If you want a non-feathered edge use the Pencil and not the Paintbrush.

You solution is only valid f you paint near the edges of the selection, it won't prevent the feathering for
brush strokes in the middle of the selection.

You can also remove the feathering on an existing selection using Select>Sharpen.

You can ask Gimp to save your preferred settings: Edit>Preferences>Tool ptions>Save tool options now

On 9/27/19 5:40 AM, GimpCrazy wrote:

Hi folks

Just thought I would share the solution to a long term problem I have been having with Gimp brushes since 2.10.

The problem: I select an object and attempt to paint it but the brush wont do a non feathered edge.

This is a problem with the settings on the selection tool not the brush.

To test: open another blank template and try out your brush on that. If it is anti-aliasing (tiny little blocks on the end) or very choppy looking blocks then the problem is the selection tool settings.

Fix: Re-select whatever it is you want to re-paint. Go to the tool settings and simply unselect the "anti-aliasing" selection. Instant hard edge. Duh. Easy once you know how.

I think it is possible that later versions of Gimp have the box checked as a default.