Sign up now! · Forgot password?
RSS/Atom feed Twitter

Script-Fu local procedure question

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

2 of 2 messages available
Toggle history

Please log in to manage your subscriptions.

Script-Fu local procedure question Helmut Jarausch via gimp-user-list 16 Apr 10:04
  Script-Fu local procedure question Ofnuts 16 Apr 20:58
Helmut Jarausch via gimp-user-list
2019-04-16 10:04:01 UTC (2 months ago)

Script-Fu local procedure question

Hi,

I have an old script-fu script which contains

(if (not convolution-preset-type-is-basic) (script-fu-register "script-fu-convolution-presets-blur-symmetric" "Symmetric Blur..."
(string-append CONV-PRESET-DESCRIPTION "(Symmetric Blur)") "Iccii "
CONV-PRESET-COPYRIGHT
CONV-PRESET-DATE
CONV-PRESET-IMAGE-TYPE
SF-IMAGE "Image" 0 SF-DRAWABLE "Drawable" 0 SF-OPTION "Matrix Type" CONV-PRESET-TYPE-LIST SF-ADJUSTMENT "Amount" '(3 1 128 1 1 0 0) SF-ADJUSTMENT "Center Value" '(1 1 128 1 1 0 0) SF-TOGGLE "Calculate Divisor" TRUE SF-TOGGLE "Alpha-weighting" TRUE SF-OPTION "Edge" CONV-PRESET-EDGE-LIST SF-TOGGLE "Gray Channel" FALSE SF-TOGGLE "Red Channel" TRUE SF-TOGGLE "Green Channel" TRUE SF-TOGGLE "Blue Channel" TRUE SF-TOGGLE "Alpha Channel" FALSE) (script-fu-menu-register "script-fu-convolution-presets-blur-symmetric" "/FX-Foundry/Convolution Matrix Presets")

)

i.e. the script-fu-register function call is within an 'if' clause. Now I get the error message

script-fu-Warning: Procedure script-fu-convolution-presets-blur-symmetric in script-fu-menu-register does not exist

What can I do about this?

Many thanks for a hint, Helmut

Ofnuts
2019-04-16 20:58:02 UTC (2 months ago)

Script-Fu local procedure question

On 4/16/19 12:04 PM, Helmut Jarausch via gimp-user-list wrote:

script-fu-Warning: Procedure
script-fu-convolution-presets-blur-symmetric in script-fu-menu-register does not exist

What can I do about this?

The registration being in an IF clause isn't a problem per se.

The FX-foundry stuff dates back to Gimp 2.6 (or 2.4?) and seems to have been unmaintained since. It could be time to retire it, or steal whatever code you need for your own scripts.