Sign up now! · Forgot password?
RSS/Atom feed Twitter

Font problem in user interface

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

8 of 8 messages available
Toggle history

Please log in to manage your subscriptions.

Font problem in user interface ladyejan 19 Jan 21:48
  Font problem in user interface rich2005 20 Jan 09:19
   Font problem in user interface Michael Schumacher 21 Jan 10:33
  Font problem in user interface Wicky 28 Apr 14:09
   Font problem in user interface Wicky 28 Apr 15:07
    Font problem in user interface Wicky 21 Jun 17:45
     Font problem in user interface Wicky 22 Jun 21:09
      Font problem in user interface iollie 23 Oct 15:31
2017-01-19 21:48:15 UTC (almost 3 years ago)
postings
1
contact
Send private message

Font problem in user interface

just downloaded GIMP for Mac, and when I open it all the text in the user interface menu is in numerical fractions.

Does anyone know a solution for this - or has had this problem?

I'd love to try out the program - but can't figure out what's what with this issue.

rich2005
2017-01-20 09:19:03 UTC (almost 3 years ago)

Font problem in user interface

just downloaded GIMP for Mac, and when I open it all the text in the user interface menu is in numerical fractions.

Does anyone know a solution for this - or has had this problem?

I'd love to try out the program - but can't figure out what's what with this issue.

It will be a language setting, the strange symbols are foreign language characters that your computer can not display. Something like : http://imgur.com/mryHNmJ

I do not use a Mac but try this https://sourceforge.net/p/gimponosx/support-requests/9/

You will have to go by position in the relevent menus on my installation it is like this: http://imgur.com/eZRFCCL

Second menu (Edit) 5 up from the bottom -> gives the preferences menu

Preferences menu, second option -> top entry and the drop down menu.

rich: www.gimp-forum.net

Michael Schumacher
2017-01-21 10:33:34 UTC (almost 3 years ago)

Font problem in user interface

On 01/20/2017 10:19 AM, rich2005 wrote:

just downloaded GIMP for Mac, and when I open it all the text in the user interface menu is in numerical fractions.

Does anyone know a solution for this - or has had this problem?

I'd love to try out the program - but can't figure out what's what with this issue.

It will be a language setting, the strange symbols are foreign language characters that your computer can not display. Something like : http://imgur.com/mryHNmJ

This makes me wonder if the most recent package for OSX is being used here - it has a fix for wrong language (i.e. one of the user's chosen, but not prefered ones) being selected for the UI language.

Regards,
Michael
GPG: 96A8 B38A 728A 577D 724D 60E5 F855 53EC B36D 4CDD
2019-04-28 14:09:21 UTC (8 months ago)
postings
4
contact
Send private message

Font problem in user interface

just downloaded GIMP for Mac, and when I open it all the text in the user interface menu is in numerical fractions.

Does anyone know a solution for this - or has had this problem?

I'd love to try out the program - but can't figure out what's what with this issue.

Same happening with my gimp install (2.10) on Mac running 10.14.4 Mojave

Working fine for a week or so then UI screwed up with fractions! Tried to look in preferences but that's turned into gibberish..

See Screenshot

Hope there's a soltion as I use Gimp for the Later alpha colour to transparency function that PS sorely lacks

2019-04-28 15:07:14 UTC (8 months ago)
postings
4
contact
Send private message

Font problem in user interface

Tried deleting prefrences plist file - deleting and reinstalling app without and any joy :-(

2019-06-21 17:45:29 UTC (6 months ago)
postings
4
contact
Send private message

Font problem in user interface

Tried deleting prefrences plist file - deleting and reinstalling app without and any joy :-(

UI Font garbling Still happening in 2.10.12

https://cl.ly/17be9a6a598a/screenshot_1430.jpg

https://cl.ly/258f4e7f7387/Image%2525202019-06-21%252520at%2525206.44.48%252520pm.png

2019-06-22 21:09:39 UTC (6 months ago)
postings
4
contact
Send private message

Font problem in user interface

SOLVED

It's a font cache issue with the Mac

http://www.fontgeek.net/blog/?p=6

Solution

clear-font-cache.md Close all applications. ( ...
Start Terminal (located in the Utilities folder; press Command-Shift-U to open this folder). Type: sudo atsutil databases -remove and press Return. Type your password at the prompt (no characters will echo back to the screen).

2019-10-23 15:31:09 UTC (about 1 month ago)
postings
1
contact
Send private message

Font problem in user interface

UNSOLVED !

i read the whole article, downloaded FontAgent9 (btw wayyys better than Fontbook but VERY expensive as an alternative) -deleted fonts caches (all), restarted, same problem :(( -made a Timemachine safe (just in case...), closed ALL apps, typed your formula in Terminal, validated with pass, got a message about fonts (so, it DID sumptin'), closed, restarted... SAME ISSUE ON GIMP 2.10.12 :((

i use Catalina 10.15 latest version today. the problem is like i had a QWERTY keyboard (i use AZERTY, I'm french) : when I type 2 i get a 4 on my box. WHEREAS in the text editor window I HAVE MY CORRECT SPELLING !

i regret my good old 2.8.2 which NEVER failed. although the selections did no more appear in Catalina.
How do we do ?

Any help that doesn't need a terminal-toolbox-specialist ? I mean, rather disappointing when my Mac ALWAYS works without having to f***k about like in Windoz.
thank you Gimpusers, i LOVE Gimp, and do NOT want anythang else.

Ollie Brenkman.

SOLVED

It's a font cache issue with the Mac

http://www.fontgeek.net/blog/?p=6

Solution

clear-font-cache.md Close all applications. ( ...
Start Terminal (located in the Utilities folder; press Command-Shift-U to open this folder).
Type: sudo atsutil databases -remove and press Return. Type your password at the prompt (no characters will echo back to the screen).

iollie (via www.gimpusers.com/forums)