Sign up now! · Forgot password?
RSS/Atom feed Twitter

Error while executing script-fu-smart-remove

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

4 of 4 messages available
Toggle history

Please log in to manage your subscriptions.

Error while executing script-fu-smart-remove GGmp 04 Aug 00:36
  Error while executing script-fu-smart-remove rich2005 05 Aug 08:04
  Error while executing script-fu-smart-remove Pat David 05 Aug 13:33
  Error while executing script-fu-smart-remove Kevin Cozens 05 Aug 23:25
2016-08-04 00:36:35 UTC (about 4 years ago)
postings
1
contact
Send private message

Error while executing script-fu-smart-remove

Hi.

I 'm using Gimp 2.8.18 and when i try to use the Heal selection filter appears the next message:

Error while executing script-fu-smart-remove Error: eval: unbound variable: plug-in synthesizer

I've searched a lot and I don't still find the solution.

Regards.

rich2005
2016-08-05 08:04:45 UTC (about 4 years ago)

Error while executing script-fu-smart-remove

Hi.

I 'm using Gimp 2.8.18 and when i try to use the Heal selection filter appears the next message:

Error while executing script-fu-smart-remove Error: eval: unbound variable: plug-in synthesizer

I've searched a lot and I don't still find the solution.

No replies? Try

This error? http://imgur.com/a/fsaFq so assuming OS = Windows of some sort

Two issues.

1. You do not have the resynthesizer plugin installed.

2. You are using an outdated script. A more recent python plugin will work better.

I did bundle everything one time.

Get http://www.mediafire.com/download/gwc928wmwti30g3/resynth_win_32_64.zip

unzip and put 3 files, plugin-heal-selection.py, resynthesizer.exe, resynthesizer-gui.exe into .gimp-2.8\plug-ins.

Choose the appropriate 32/64 bit versions.

Remove the old smart-remove.scm file to prevent conflicts.

Pat David
2016-08-05 13:33:28 UTC (about 4 years ago)

Error while executing script-fu-smart-remove

Hi!

This filter requires that the Resynthesizer plugin is installed. This is not a plugin that is maintained by the GIMP developers: https://github.com/bootchk/resynthesizer

If you need inpainting you could also try one of the methods available in G'MIC as well (http://gmic.eu)
On Thu, Aug 4, 2016 at 1:36 PM GGmp wrote:

Hi.

I 'm using Gimp 2.8.18 and when i try to use the Heal selection filter appears
the next message:

Error while executing script-fu-smart-remove Error: eval: unbound variable: plug-in synthesizer

I've searched a lot and I don't still find the solution.

Regards.

-- GGmp (via www.gimpusers.com/forums)
_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

Pat David
https://pixls.us
http://blog.patdavid.net
Kevin Cozens
2016-08-05 23:25:10 UTC (about 4 years ago)

Error while executing script-fu-smart-remove

On 16-08-03 08:36 PM, GGmp wrote: > I 'm using Gimp 2.8.18 and when i try to use the Heal selection filter appears
> the next message:
>
> Error while executing script-fu-smart-remove > Error: eval: unbound variable: plug-in synthesizer

If you had done a search using the words "gimp unbound variable" you would have found the solution on the page
https://www.gimp.org/docs/script-fu-update.html

You have an old script that is using a variable before it was defined. Make sure your variables are defined before you use them.

Cheers!

Kevin.

http://www.ve3syb.ca/           |"Nerds make the shiny things that distract
Owner of Elecraft K2 #2172      | the mouth-breathers, and that's why we're
                                 | powerful!"
#include  |             --Chris Hardwick