Sign up now! · Forgot password?
RSS/Atom feed Twitter

GIMP crashes with a "LibGimp-WARNING **: script-fu: wire_read: unexpected EOF" error

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

Steve Chaney
2002-05-28 03:38:49 UTC (over 19 years ago)

GIMP crashes with a "LibGimp-WARNING **: script-fu: wire_read: unexpected EOF" error

Is there any info on what might be causing this error:

LibGimp-WARNING **: script-fu: wire_read: unexpected EOF ?

I have checked the message boards. They said to configure with --disable-perl to stop this from happening. I did that. It still crashed.

I tried to find out what libs might be causing this crash. I updated Gtk-Perl and PERL itself, according to advice I saw on the web, but this is still happening :(

The only way I see now to avoid this crash, is to disable script-fu. Is there a setting in the config.h or the configure script itself that I need to call on, to stop GIMP from using script-fu at all?

Or am I totally SOL here?

BTW I am using redhat 7.2 and my compiler is GCC 2.96 and egcs 2.91-66. I am trying to compile GIMP 1.2.2 and 1.2.3.

-- Steve

Joel
2002-05-28 19:48:42 UTC (over 19 years ago)

GIMP crashes with a "LibGimp-WARNING **: script-fu: wire_read: unexpected EOF" error

It might just be a screwy script. Try running Gimp from the command line, with gimp --verbose. Right before it crashes, it'll tell you which plug-in it's trying to load. Remove the plugin from the plug-ins directory and try again.

There is no simple setting to disable script-fu, though you could probably modify the configure script and Makefiles, completely excising anthing having to do with script-fu. No telling how much mucking with the source you'd need to do to get it to compile, though, and when it did compile, it'd be *severely* limited.

--Joel

LibGimp-WARNING **: script-fu: wire_read: unexpected EOF ?

I have checked the message boards. They said to configure with --disable-perl to stop this from happening. I did that. It still crashed.

I tried to find out what libs might be causing this crash. I updated Gtk-Perl and PERL itself, according to advice I saw on the web, but this is still happening :(

The only way I see now to avoid this crash, is to disable script-fu. Is there a setting in the config.h or the configure script itself that I need to call on, to stop GIMP from using script-fu at all?

Or am I totally SOL here?

BTW I am using redhat 7.2 and my compiler is GCC 2.96 and egcs 2.91-66. I am trying to compile GIMP 1.2.2 and 1.2.3.

-- Steve