Sign up now! · Forgot password?
RSS/Atom feed Twitter

controlling background color

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

6 of 6 messages available
Toggle history

Please log in to manage your subscriptions.

controlling background color Spencer Graves 21 Dec 09:20
  controlling background color Spencer Graves 21 Dec 16:57
   controlling background color Alexandre Prokoudine via gimp-user-list 21 Dec 17:01
    controlling background color Spencer Graves 21 Dec 17:35
     controlling background color Daumail Alain via gimp-user-list 21 Dec 18:01
      controlling background color Spencer Graves 21 Dec 18:11
Spencer Graves
2018-12-21 09:20:40 UTC (about 1 month ago)

controlling background color

      How can I control background color?

      I've done File > Open > [a png file with a transparent background].

      This gives me an image with a transparent background.  I need a white background.  I try Layer > "New Layer" > White, and the layer is NOT white but a teal green that matches one of the colors in the image I opened.  Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white.  Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image.  I've tried using the "Bucket Fill" tool with the new layer, so far without success.

      The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this).  I'm using it in a place with a black background, and all the lettering disappears.  See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

      I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

      The capability surely exists.  Sadly, my web search efforts and experimentation have so far failed to find how to fix this.

      Suggestions?       Thanks,
      Spencer Graves

Spencer Graves
2018-12-21 16:57:16 UTC (about 1 month ago)

controlling background color

      I solved this problem following a post "Re: frustrated" by Alexandre Prokoudine via gimp-user-list .  Prokoudine suggested starting File > New.  I did that, specifying width and height to match the image for which I wanted white (not transparent) background.  I also clicked "Advanced Options" > "Fill with" White, then "OK".  Then I copied the image for which I needed a white background and pasted it onto the new file.  File > "Export as" png confirmed that I had fixed the problem.

      Someone else could probably provide an easier, more direct way to do this, but this worked.

      Thanks,       Spencer Graves

On 2018-12-21 03:20, Spencer Graves wrote:

How can I control background color?

      I've done File > Open > [a png file with a transparent background].

      This gives me an image with a transparent background.  I need a white background.  I try Layer > "New Layer" > White, and the layer is NOT white but a teal green that matches one of the colors in the image I opened.  Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white.  Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image.  I've tried using the "Bucket Fill" tool with the new layer, so far without success.

      The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this).  I'm using it in a place with a black background, and all the lettering disappears.  See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

      I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

      The capability surely exists.  Sadly, my web search efforts and experimentation have so far failed to find how to fix this.

      Suggestions?       Thanks,
      Spencer Graves

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives:   https://mail.gnome.org/archives/gimp-user-list

Alexandre Prokoudine via gimp-user-list
2018-12-21 17:01:21 UTC (about 1 month ago)

controlling background color

Spencer,

I tried replicating the issue you ran into and didn't manage to. If you can share your PNG file, that might help (if there's a bug in GIMP).

Alex

On Fri, Dec 21, 2018 at 7:58 PM Spencer Graves wrote:

I solved this problem following a post "Re: frustrated" by Alexandre Prokoudine via gimp-user-list . Prokoudine suggested starting File > New. I did that, specifying width and height to match the image for which I wanted white (not transparent) background. I also clicked "Advanced Options" > "Fill with" White, then "OK". Then I copied the image for which I needed a white background and pasted it onto the new file. File > "Export as" png confirmed that I had fixed the problem.

Someone else could probably provide an easier, more direct way to do this, but this worked.

Thanks, Spencer Graves

On 2018-12-21 03:20, Spencer Graves wrote:

How can I control background color?

I've done File > Open > [a png file with a transparent background].

This gives me an image with a transparent background. I need a white background. I try Layer > "New Layer" > White, and the layer is NOT white but a teal green that matches one of the colors in the image I opened. Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white. Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image. I've tried using the "Bucket Fill" tool with the new layer, so far without success.

The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this). I'm using it in a place with a black background, and all the lettering disappears. See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

The capability surely exists. Sadly, my web search efforts and experimentation have so far failed to find how to fix this.

Suggestions? Thanks,
Spencer Graves

_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

Spencer Graves
2018-12-21 17:35:30 UTC (about 1 month ago)

controlling background color

On 2018-12-21 11:01, Alexandre Prokoudine wrote:

Spencer,

I tried replicating the issue you ran into and didn't manage to. If you can share your PNG file, that might help (if there's a bug in GIMP).

      See
"https://www.dropbox.com/sh/uwxubmh4lcoxx3n/AABUbehkTYfKd0InpenoyEZXa?dl=0". This contains "CCL-Logo-H2.png" and "CCL-Logo1_6.xcf".  I imported the png file, did Image > "Canvas size" > [Height = 251, y = 96] > Resize, then saved the result as the xcf file.

      If the dropbox link doesn't work for you, please suggest how I can get around this problem.  My initial post had the png file attached, but the mailman software stripped it.

      Thanks,       Spencer

Alex

On Fri, Dec 21, 2018 at 7:58 PM Spencer Graves wrote:

I solved this problem following a post "Re: frustrated" by Alexandre Prokoudine via gimp-user-list . Prokoudine suggested starting File > New. I did that, specifying width and height to match the image for which I wanted white (not transparent) background. I also clicked "Advanced Options" > "Fill with" White, then "OK". Then I copied the image for which I needed a white background and pasted it onto the new file. File > "Export as" png confirmed that I had fixed the problem.

Someone else could probably provide an easier, more direct way to do this, but this worked.

Thanks, Spencer Graves

On 2018-12-21 03:20, Spencer Graves wrote:

How can I control background color?

I've done File > Open > [a png file with a transparent background].

This gives me an image with a transparent background. I need a white background. I try Layer > "New Layer" > White, and the layer is NOT white but a teal green that matches one of the colors in the image I opened. Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white. Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image. I've tried using the "Bucket Fill" tool with the new layer, so far without success.

The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this). I'm using it in a place with a black background, and all the lettering disappears. See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

The capability surely exists. Sadly, my web search efforts and experimentation have so far failed to find how to fix this.

Suggestions? Thanks,
Spencer Graves

_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

Daumail Alain via gimp-user-list
2018-12-21 18:01:07 UTC (about 1 month ago)

controlling background color

The png image is in indexed color mode.

I presume that white or black is not one of the colors in the original image.

Setting Image in RGB mode ( Image > mode > RGB ) permits the usage of all colors.

yours, Alain

Le 21/12/2018 à 18:35, Spencer Graves a écrit :

On 2018-12-21 11:01, Alexandre Prokoudine wrote:

Spencer,

I tried replicating the issue you ran into and didn't manage to. If you can share your PNG file, that might help (if there's a bug in GIMP).

      See
"https://www.dropbox.com/sh/uwxubmh4lcoxx3n/AABUbehkTYfKd0InpenoyEZXa?dl=0". This contains "CCL-Logo-H2.png" and "CCL-Logo1_6.xcf".  I imported the png file, did Image > "Canvas size" > [Height = 251, y = 96] > Resize, then saved the result as the xcf file.

      If the dropbox link doesn't work for you, please suggest how I can get around this problem.  My initial post had the png file attached, but the mailman software stripped it.

      Thanks,       Spencer

Alex

On Fri, Dec 21, 2018 at 7:58 PM Spencer Graves wrote:

        I solved this problem following a post "Re: frustrated" by Alexandre Prokoudine via gimp-user-list . Prokoudine suggested starting File > New.  I did that, specifying width and height to match the image for which I wanted white (not transparent)
background.  I also clicked "Advanced Options" > "Fill with" White, then
"OK".  Then I copied the image for which I needed a white background and
pasted it onto the new file.  File > "Export as" png confirmed that I had fixed the problem.

        Someone else could probably provide an easier, more direct way to
do this, but this worked.

        Thanks,         Spencer Graves

On 2018-12-21 03:20, Spencer Graves wrote:

How can I control background color?

       I've done File > Open > [a png file with a transparent background].

       This gives me an image with a transparent background.  I need a white background.  I try Layer > "New Layer" > White, and the layer is NOT white but a teal green that matches one of the colors in the image I opened.  Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white. Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image.  I've tried using the "Bucket Fill" tool with the new layer, so far without success.

       The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this).  I'm using it in a place with a black background, and all the lettering disappears.  See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

       I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

       The capability surely exists.  Sadly, my web search efforts and experimentation have so far failed to find how to fix this.

       Suggestions?        Thanks,
       Spencer Graves

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership:
https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives:   https://mail.gnome.org/archives/gimp-user-list

Spencer Graves
2018-12-21 18:11:31 UTC (about 1 month ago)

controlling background color

On 2018-12-21 12:01, Daumail Alain via gimp-user-list wrote:

The png image is in indexed color mode.

I presume that white or black is not one of the colors in the original image.

Setting Image in RGB mode ( Image > mode > RGB ) permits the usage of all colors.

      Great.  That's it.  After that, I could do Layer > "New Layer" > "Fill with:  White", and actually get white!

      Thanks.  Spencer

yours, Alain

Le 21/12/2018 à 18:35, Spencer Graves a écrit :

On 2018-12-21 11:01, Alexandre Prokoudine wrote:

Spencer,

I tried replicating the issue you ran into and didn't manage to. If you can share your PNG file, that might help (if there's a bug in GIMP).

      See
"https://www.dropbox.com/sh/uwxubmh4lcoxx3n/AABUbehkTYfKd0InpenoyEZXa?dl=0". This contains "CCL-Logo-H2.png" and "CCL-Logo1_6.xcf".  I imported the png file, did Image > "Canvas size" > [Height = 251, y = 96] > Resize, then saved the result as the xcf file.

      If the dropbox link doesn't work for you, please suggest how I can get around this problem.  My initial post had the png file attached, but the mailman software stripped it.

      Thanks,       Spencer

Alex

On Fri, Dec 21, 2018 at 7:58 PM Spencer Graves wrote:

        I solved this problem following a post "Re: frustrated" by Alexandre Prokoudine via gimp-user-list . Prokoudine suggested starting File > New.  I did that, specifying width
and height to match the image for which I wanted white (not transparent)
background.  I also clicked "Advanced Options" > "Fill with" White, then
"OK".  Then I copied the image for which I needed a white background and
pasted it onto the new file.  File > "Export as" png confirmed that I had fixed the problem.

        Someone else could probably provide an easier, more direct way to
do this, but this worked.

        Thanks,         Spencer Graves

On 2018-12-21 03:20, Spencer Graves wrote:

How can I control background color?

       I've done File > Open > [a png file with a transparent background].

       This gives me an image with a transparent background.  I need a
white background.  I try Layer > "New Layer" > White, and the layer is
NOT white but a teal green that matches one of the colors in the image
I opened.  Layer > "New Layer" > "Background color" gives me the same teal green, which the computer seems to think is white. Layer > "New Layer" > "Foreground color" gives me black, which matches another of the colors in the image.  I've tried using the "Bucket Fill" tool with
the new layer, so far without success.

       The image I'm trying to modify is the logo for the Citizens' Climate Lobby, "CCL-Logo-H2.png", which I found by downloading the entire web page from their web site (attached, in case your email system will support this).  I'm using it in a place with a black background, and all the lettering disappears.  See "www.kkfi.org/program-episodes/citizens-climate-lobby-carbon-fee-dividend".

       I've tried this with both GIMP 2.10.8 and 2.8.22 under macOS 10.14.2.

       The capability surely exists.  Sadly, my web search efforts and
experimentation have so far failed to find how to fix this.

       Suggestions?        Thanks,
       Spencer Graves

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership:
https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership:
https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives:   https://mail.gnome.org/archives/gimp-user-list

_______________________________________________ gimp-user-list mailing list
List address:    gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives:   https://mail.gnome.org/archives/gimp-user-list