Sign up now! · Forgot password?
RSS/Atom feed Twitter

Install Layers FX plugin

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

10 of 10 messages available
Toggle history

Please log in to manage your subscriptions.

Install Layers FX plugin Loriblackdog 26 Sep 12:56
  Install Layers FX plugin rich404 26 Sep 14:21
   Install Layers FX plugin Loriblackdog 26 Sep 15:38
    Install Layers FX plugin rich404 26 Sep 15:45
     Install Layers FX plugin Loriblackdog 26 Sep 17:35
      Install Layers FX plugin rich404 26 Sep 17:51
       Install Layers FX plugin Loriblackdog 28 Sep 09:03
        Install Layers FX plugin rich404 28 Sep 11:48
   Install Layers FX plugin Valci 20 Feb 20:24
    Install Layers FX plugin rich404 21 Feb 08:37
2018-09-26 12:56:43 UTC (6 months ago)
postings
4
contact
Send private message

Install Layers FX plugin

Hi All

I am new and have been trying to install the Layers fx plugin to no avail?? Can someone send me a link to download this plugin?

Thank you Loriblackdog

2018-09-26 14:21:29 UTC (6 months ago)
postings
362
contact
Send private message

Install Layers FX plugin

Hi All

I am new and have been trying to install the Layers fx plugin to no avail?? Can someone send me a link to download this plugin?

Thank you Loriblackdog

The old gimp-plugin-registry site is gone. There were 3 versions of layerfx. Assuming you are using Windows, the attached is a slightly tweaked version for Gimp 2.10

Unzip it, and pop in your Gimp profile plug-ins folder C:\Users\your-name\AppData\Roaming\GIMP\2.10\plug-ins

screenshot https://i.imgur.com/z7zcMsd.jpg

Find it bottom of the layers menu (also in right click in layers dialogue)

https://i.imgur.com/YFVV6US.jpg

It is one of the plugins that are not very happy with Gimp 2.10 / 32bit python 2.7.15 Some filters do not work.

Work-arounds. The python color picker crashes. Set the FG color first, then right-click in the dialogue, choose FG color.

https://i.imgur.com/uiSxStG.jpg

As the name implies, it works on layers, depending on filter & settings remember to size any text layers to suit.

https://i.imgur.com/DnQW1WQ.jpg

If you want an earlier / Gimp 2.8 version just ask.

2018-09-26 15:38:42 UTC (6 months ago)
postings
4
contact
Send private message

Install Layers FX plugin

The old gimp-plugin-registry site is gone. There were 3 versions of layerfx. Assuming you are using Windows, the attached is a slightly tweaked version for Gimp 2.10

Unzip it, and pop in your Gimp profile plug-ins folder C:\Users\your-name\AppData\Roaming\GIMP\2.10\plug-ins

screenshot https://i.imgur.com/z7zcMsd.jpg

Find it bottom of the layers menu (also in right click in layers dialogue)

https://i.imgur.com/YFVV6US.jpg

It is one of the plugins that are not very happy with Gimp 2.10 / 32bit python 2.7.15 Some filters do not work.

Work-arounds. The python color picker crashes. Set the FG color first, then right-click in the dialogue, choose FG color.

https://i.imgur.com/uiSxStG.jpg

As the name implies, it works on layers, depending on filter & settings remember to size any text layers to suit.

https://i.imgur.com/DnQW1WQ.jpg

If you want an earlier / Gimp 2.8 version just ask.

Hi Rich,
I didn't see the zip file? I am missing something? Can you send me the zip file? I would greatly appreciate any help you can send my way.

Thank you Loriblackdog

2018-09-26 15:45:57 UTC (6 months ago)
postings
362
contact
Send private message

Install Layers FX plugin

Hi Rich,
I didn't see the zip file? I am missing something? Can you send me the zip file? I would greatly appreciate any help you can send my way.

Thank you
Loriblackdog

Are you using the mailing list or the forum? I only use the forum. Right hand side of the post,

However try this.

http://www.gimpusers.com/system/attachments/1019/original/LayerFX-210.py.zip?1537971689

2018-09-26 17:35:20 UTC (6 months ago)
postings
4
contact
Send private message

Install Layers FX plugin

Are you using the mailing list or the forum? I only use the forum. Right hand side of the post,

However try this.

http://www.gimpusers.com/system/attachments/1019/original/LayerFX-210.py.zip?1537971689

Hi Rich,

Google chrome blocked me from downloading stating potential malware? How can I be sure this is safe to do?, Like I said I am new to this and would like to know?

thank you

Loriblackdog

2018-09-26 17:51:12 UTC (6 months ago)
postings
362
contact
Send private message

Install Layers FX plugin

Hi Rich,

Google chrome blocked me from downloading stating potential malware? How can I be sure this is safe to do?, Like I said I am new to this and would like to know?

thank you

Loriblackdog

It is up to you, nothing wrong with the file(s) Could be because it is 'python' and thus a 'program'

Run it through virustotal.com

Done it for you

This one the zip as you would download. https://i.imgur.com/zh2Ndr5.jpg

this one the file in the zip https://i.imgur.com/TWR6Y7N.jpg

I use linux and do not have to through that rigmarole.

2018-09-28 09:03:35 UTC (6 months ago)
postings
4
contact
Send private message

Install Layers FX plugin

It is up to you, nothing wrong with the file(s) Could be because it is 'python' and thus a 'program'

Run it through virustotal.com

Done it for you

This one the zip as you would download. https://i.imgur.com/zh2Ndr5.jpg

this one the file in the zip https://i.imgur.com/TWR6Y7N.jpg

I use linux and do not have to through that rigmarole.

Hi Rich,

It has been 3 days and I still cannot get this plugin installed, McAfee has it blocked and I cannot even look at it.? Is anyone else having this problem? Isn't there a workaround? Like I said I am new to this and it is very very FRUSTRATING. Thank yLoriblackdog

y

2018-09-28 11:48:44 UTC (6 months ago)
postings
362
contact
Send private message

Install Layers FX plugin

Hi Rich,

It has been 3 days and I still cannot get this plugin installed, McAfee has it blocked and I cannot even look at it.? Is anyone else having this problem? Isn't there a workaround? Like I said I am new to this and it is very very FRUSTRATING. Thank yLoriblackdog

y

Not going to make much difference wherever I point you to, since it looks like your AV will stop any file with a .py suffix.

The old registry.gimp.org site was backed up as an archive and you can browse through the files

https://github.com/pixlsus/registry.gimp.org_static/tree/master/registry.gimp.org/files

The one you want is:

https://github.com/pixlsus/registry.gimp.org_static/raw/master/registry.gimp.org/files/layerfx.2.8.py.txt

Note the .txt suffix. You will have to remove that for the plugin to work eg. rename to layerfx28.py

I have found even that defeats some Windows users, so best of luck.

2019-02-20 20:24:22 UTC (28 days ago)
postings
1
contact
Send private message

Install Layers FX plugin

Hi Rich!

I need the 2.8 version, could you please attach it?

Thank you veerrry much!

The old gimp-plugin-registry site is gone. There were 3 versions of layerfx. Assuming you are using Windows, the attached is a slightly tweaked version for Gimp 2.10

Unzip it, and pop in your Gimp profile plug-ins folder C:\Users\your-name\AppData\Roaming\GIMP\2.10\plug-ins

screenshot https://i.imgur.com/z7zcMsd.jpg

Find it bottom of the layers menu (also in right click in layers dialogue)

https://i.imgur.com/YFVV6US.jpg

It is one of the plugins that are not very happy with Gimp 2.10 / 32bit python 2.7.15 Some filters do not work.

Work-arounds. The python color picker crashes. Set the FG color first, then right-click in the dialogue, choose FG color.

https://i.imgur.com/uiSxStG.jpg

As the name implies, it works on layers, depending on filter & settings remember to size any text layers to suit.

https://i.imgur.com/DnQW1WQ.jpg

If you want an earlier / Gimp 2.8 version just ask.

2019-02-21 08:37:22 UTC (28 days ago)
postings
362
contact
Send private message

Install Layers FX plugin

Hi Rich!

I need the 2.8 version, could you please attach it?

Thank you veerrry much!

I put both layerfx.py and layerfx28.py in the zip. If using Gimp 2.8.x then layerfx28.py with layer groups works OK. For Gimp 2.10 layerfx28.py is broken in the layergroups use the older layerfx.py

This is an old plugin, not maintained and at 6600 lines nobody seems keen to take it on.