Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Inital zoom ratio bug?

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

7 of 7 messages available
Toggle history

Please log in to manage your subscriptions.

Inital zoom ratio bug? berniek 12 May 22:48
  Inital zoom ratio bug? Richard Gitschlag 13 May 16:12
   Inital zoom ratio bug? Partha Bagchi 13 May 16:22
    Inital zoom ratio bug? berniek 13 May 19:13
     Inital zoom ratio bug? Partha Bagchi 13 May 19:17
     Inital zoom ratio bug? Richard Gitschlag 13 May 19:59
      Inital zoom ratio bug? berniek 13 May 21:44
2012-05-12 22:48:46 UTC (about 2 years ago)
postings
5
contact
Send private message

Inital zoom ratio bug?

So I'm using Gimp 2.8 in single window mode and not fullscreen window on winXp. Initial zoom ratio is set to "Fit to window". And yet when I open a big image which wouldn't fit to Gimp's window, Gimp still resize its own window even to out of my screen's resolution boundary. I don't want that. My pref window: http://i.imgur.com/fVHaR.jpg So is this bug or how can I prevent Gimp doing this? Thanks for any answers!

Richard Gitschlag
2012-05-13 16:12:41 UTC (about 2 years ago)

Inital zoom ratio bug?

Date: Sun, 13 May 2012 00:48:46 +0200 From: forums@gimpusers.com
To: gimp-user-list@gnome.org
CC: team@gimpusers.com
Subject: [Gimp-user] Inital zoom ratio bug?

So I'm using Gimp 2.8 in single window mode and not fullscreen window on winXp. Initial zoom ratio is set to "Fit to window". And yet when I open a big image which wouldn't fit to Gimp's window, Gimp still resize its own window even to out of my screen's resolution boundary. I don't want that. My pref window: http://i.imgur.com/fVHaR.jpg So is this bug or how can I prevent Gimp doing this? Thanks for any answers!

--
berniek (via gimpusers.com)

That is odd. I have the same settings (including single-window mode, with my window carefully sized/placed to fill the whole screen because there's a bug with maximized window status) and have yet to encounter the problem.

Hmm ... I have an idea what could be responsible (though exactly why fails me), so try these steps:

1 - Size your GIMP window as desired. 2 - Go to the "Window Management" section of Preferences and hit the button for "Save Window Positions Now". 3 - Restart GIMP and see if the behavior persists.

-- Stratadrake strata_ranger@hotmail.com
--------------------
Numbers may not lie, but neither do they tell the whole truth.

Partha Bagchi
2012-05-13 16:22:04 UTC (about 2 years ago)

Inital zoom ratio bug?

On Sun, May 13, 2012 at 12:12 PM, Richard Gitschlag wrote:

Date: Sun, 13 May 2012 00:48:46 +0200 From: forums@gimpusers.com
To: gimp-user-list@gnome.org
CC: team@gimpusers.com
Subject: [Gimp-user] Inital zoom ratio bug?

So I'm using Gimp 2.8 in single window mode and not fullscreen window on winXp. Initial zoom ratio is set to "Fit to window". And yet when I open a big image which wouldn't fit to Gimp's window, Gimp still resize its own window even to out of my screen's resolution boundary. I don't want that. My pref window: http://i.imgur.com/fVHaR.jpg So is this bug or how can I prevent Gimp doing this? Thanks for any answers!

--
berniek (via gimpusers.com)

That is odd. I have the same settings (including single-window mode, with my window carefully sized/placed to fill the whole screen because there's a bug with maximized window status) and have yet to encounter the problem.

Hmm ... I have an idea what could be responsible (though exactly why fails me), so try these steps:

1 - Size your GIMP window as desired. 2 - Go to the "Window Management" section of Preferences and hit the button for "Save Window Positions Now".
3 - Restart GIMP and see if the behavior persists.

-- Stratadrake strata_ranger@hotmail.com
--------------------
Numbers may not lie, but neither do they tell the whole truth.

_______________________________________________ gimp-user-list mailing list
gimp-user-list@gnome.org
http://mail.gnome.org/mailman/listinfo/gimp-user-list

When using single-window mode, try tuning off fit-to-window etc. by unchecking resize and zoom behavior.

2012-05-13 19:13:04 UTC (about 2 years ago)
postings
5
contact
Send private message

Inital zoom ratio bug?

Yes, I would switch it off if it hadn't been switched off already (see my linked image in earlier post). Anyway currently doing what Richard said. At least Gimp won't save the position. But it sure sounds like a bug. I have further inspected my problem and it seems Gimp has a minimal window size that will resize to no matter what preferences I set for it. To reproduce the bug:
1. make singlemode window,
2. Resize Gimp's window the smallest you can (for me it's 454x591) 2. switch off zoom & resize behavior, 3. drag and drop (or file/open) an oversized image on Gimp, 4. Boom! Resized window!
I just wish I know where to look for this in the source files. :/

Partha Bagchi
2012-05-13 19:17:27 UTC (about 2 years ago)

Inital zoom ratio bug?

I would file a bug and inform Martin.

On Sun, May 13, 2012 at 3:13 PM, berniek wrote:

Yes, I would switch it off if it hadn't been switched off already (see my linked image in earlier post). Anyway currently doing what Richard said. At least Gimp won't save the position. But it sure sounds like a bug. I have further inspected my problem and it seems Gimp has a minimal window size that will resize to no matter what preferences I set for it. To reproduce the bug:
1. make singlemode window,
2. Resize Gimp's window the smallest you can (for me it's 454x591) 2. switch off zoom & resize behavior, 3. drag and drop (or file/open) an oversized image on Gimp, 4. Boom! Resized window!
I just wish I know where to look for this in the source files. :/

-- berniek (via gimpusers.com)
_______________________________________________ gimp-user-list mailing list
gimp-user-list@gnome.org
http://mail.gnome.org/mailman/listinfo/gimp-user-list

Richard Gitschlag
2012-05-13 19:59:31 UTC (about 2 years ago)

Inital zoom ratio bug?

But it sure sounds like a bug. I have further inspected my problem

and it seems Gimp has a minimal window size that will resize to no matter what preferences I set for it.

To reproduce the bug:
1. make singlemode window,
2. Resize Gimp's window the smallest you can (for me it's 454x591) 2. switch off zoom & resize behavior, 3. drag and drop (or file/open) an oversized image on Gimp, 4. Boom! Resized window!
I just wish I know where to look for this in the source files. :/

Let's compare: My GIMP's minimum window size is (458x607), window border and title bar included. When I open an image, GIMP resizes its window to a minimum of (875x563) (border and titlebar still included) - however, this is not a problem since my saved window settings are normally about (1024x768).

Wait -- what desktop resolution do you run? A minimum width of 875 would definitely be an issue if you're running 800x600 or less.

-- Stratadrake strata_ranger@hotmail.com
--------------------
Numbers may not lie, but neither do they tell the whole truth.

2012-05-13 21:44:42 UTC (about 2 years ago)
postings
5
contact
Send private message

Inital zoom ratio bug?

I'm working on 1152x864 resolution. Gimp is positioned at the lower-right corner of the screen so I can drag&drop images easily into it. That's why it's very bad news if Gimp resizes itself. Anyway I had to go deeper. And my finding is that some nasty things are going on in gimp_display_shell_set_initial_scale() function. :D screen_width = gdk_screen_get_width (screen) * 0.75; screen_height = gdk_screen_get_height (screen) * 0.75; shell_width = SCALEX (shell, image_width); shell_height = SCALEY (shell, image_height); if (shell_width > screen_width || shell_height > screen_height) These are just not right, Gimp shouldn't care about my screen resolution at this point. Anyway I'm off to Partha's site for the Gimp compiling tutorial. And thank you guys for the help. Gimp is a very good program, although it has its flaws, I still really appreciate what the devs do.