Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

LibreJS and Gimp.org

This discussion is connected to the gimp-web-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

10 of 10 messages available
Toggle history

Please log in to manage your subscriptions.

LibreJS and Gimp.org Jackson 02 Jun 14:06
  LibreJS and Gimp.org Michael Schumacher 02 Jun 14:32
   LibreJS and Gimp.org Niel 02 Jun 19:36
  LibreJS and Gimp.org Patrick Shanahan 02 Jun 18:33
   LibreJS and Gimp.org Loic J. Duros 02 Jun 20:57
   LibreJS and Gimp.org Loic J. Duros 05 Jun 02:11
    LibreJS and Gimp.org Loic J. Duros 05 Jun 02:13
  LibreJS and Gimp.org Niel 02 Jun 19:36
   LibreJS and Gimp.org Loic J. Duros 02 Jun 20:54
LibreJS and Gimp.org Loic J. Duros 02 Jun 18:34
Jackson
2012-06-02 14:06:50 UTC (over 2 years ago)

LibreJS and Gimp.org

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

Michael Schumacher
2012-06-02 14:32:36 UTC (over 2 years ago)

LibreJS and Gimp.org

On 02.06.2012 16:06, Jackson wrote:

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

Does LibreJS provide anything that would help to identify the problem? Or is there some other thing we could use to check for problems?

Regards, Michael

Patrick Shanahan
2012-06-02 18:33:27 UTC (over 2 years ago)

LibreJS and Gimp.org

* Jackson [06-02-12 10:07]:

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

works for me.....

Loic J. Duros
2012-06-02 18:34:59 UTC (over 2 years ago)

LibreJS and Gimp.org

Hi:

I'm the maintainer of GNU LibreJS. Although this issue might be related to something on the gimp.org's page, it's the responsibility of LibreJS to properly load any page with or without JavaScript. I'll look into this and see if it is related to a bug in LibreJS.

Many thanks for reporting this issue,

Loic Duros

Niel
2012-06-02 19:36:04 UTC (over 2 years ago)

LibreJS and Gimp.org

Sorry Jackson, intended to reply to the list

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

This shows up in Firefox's error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8050000e (NS_ERROR_ILLEGAL_INPUT) [nsIScriptableUnicodeConverter.ConvertToUnicode]" nsresult: "0x8050000e (NS_ERROR_ILLEGAL_INPUT)" location: "JS frame :: resource://jid1-ktlzuoiikvffew-at-jetpack/api-utils/lib/cuddlefish.js -> resource://jid1-ktlzuoiikvffew-at-jetpack/librejs/lib/html_script_finder/dom_handler/request.js :: :: line 88" data: no]

It looks to me that the immediate problem is with LibreJS. Until it loads the page without an exception the JS cannot be easily checked, i.e it would have to be done manually.

-- Niel Archer
niel.archer (at) blueyonder.co.uk

Niel
2012-06-02 19:36:04 UTC (over 2 years ago)

LibreJS and Gimp.org

Sorry Michael, intended to reply to the list

On 02.06.2012 16:06, Jackson wrote:

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

Does LibreJS provide anything that would help to identify the problem? Or is there some other thing we could use to check for problems?

http://www.gnu.org/software/librejs/free-your-javascript.html

The LibreJS add-on to IceCat, IceWeasel, and mozilla based browsers identifies blocked and passed JS.

-- Niel Archer
niel.archer (at) blueyonder.co.uk

Loic J. Duros
2012-06-02 20:54:14 UTC (over 2 years ago)

LibreJS and Gimp.org

On 06/02/2012 03:36 PM, Niel wrote:

Sorry Jackson, intended to reply to the list

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

This shows up in Firefox's error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8050000e (NS_ERROR_ILLEGAL_INPUT) [nsIScriptableUnicodeConverter.ConvertToUnicode]" nsresult: "0x8050000e (NS_ERROR_ILLEGAL_INPUT)" location: "JS frame :: resource://jid1-ktlzuoiikvffew-at-jetpack/api-utils/lib/cuddlefish.js -> resource://jid1-ktlzuoiikvffew-at-jetpack/librejs/lib/html_script_finder/dom_handler/request.js :: :: line 88" data: no]

It looks to me that the immediate problem is with LibreJS. Until it loads the page without an exception the JS cannot be easily checked, i.e it would have to be done manually.

The issue is a new module of LibreJS which was developed so that it can be compatible with Https-Everywhere. Some of the JavaScript files in gimp.org are detected as latin-1, apparently. I'll work on fixing this issue.

Loic J. Duros
2012-06-02 20:57:38 UTC (over 2 years ago)

LibreJS and Gimp.org

On 06/02/2012 02:33 PM, Patrick Shanahan wrote:

* Jackson [06-02-12 10:07]:

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

To temporarily address this issue, you can either use LibreJS 4.6, which doesn't use the same request module, or add gimp.org to the whitelist from the about:addons preferences page.

Thanks,

Loic J. Duros
2012-06-05 02:11:53 UTC (over 2 years ago)

LibreJS and Gimp.org

* Jackson [06-02-12 10:07]:

Gimp.org does not work with https://www.gnu.org/software/librejs/ Doesn't load.

Hello:

I wanted to mention on this list that I've updated LibreJS to fix the bug it had visiting gimp.org. You might want to try to install LibreJS version 4.7.1 and check if gimp.org is loading properly now.

You should see when clicking on the LibreJS widget (bottom right in addon bar) that the scripts are all blocked except for jQuery. It would be great for your visitors to release these scripts under a free license so that they can be detected by LibreJS properly: http://www.gnu.org/software/librejs/free-your-javascript.html

For more information on why it is important to make JavaScript code free, please read: http://www.gnu.org/philosophy/javascript-trap.html

Many thanks!

Loic Duros

Loic J. Duros
2012-06-05 02:13:31 UTC (over 2 years ago)

LibreJS and Gimp.org

On 06/04/2012 10:11 PM, Loic J. Duros wrote:

You might want to try to install LibreJS version 4.7.1 and check if gimp.org is loading properly now.

I forgot to add the direct link to the add-on: http://ftp.gnu.org/gnu/librejs/librejs-4.7.1.xpi and to the project page: http://www.gnu.org/software/librejs/

Thanks!