Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Problem building on Solaris 11

This discussion is connected to the gegl-developer-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

2 of 2 messages available
Toggle history

Please log in to manage your subscriptions.

Problem building on Solaris 11 Brandon Barker 09 May 18:24
  Problem building on Solaris 11 rassahah@googlemail.com 12 May 16:39
Brandon Barker
2012-05-09 18:24:08 UTC (almost 2 years ago)

Problem building on Solaris 11

Hello,

I'm trying to build gegl 0.2.0 on Solaris 11, with the following configuration options (note that I just build babl 0.1.10 and installed it in /usr/local):
CFLAGS="-I/usr/local/include" CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib" BABL_CFLAGS="-I/usr/local/include/babl-0.1" BABL_LIBS="-L/usr/local/lib/babl-0.1" ./configure echo $PATH
/usr/local/bin:/usr/bin:/bin

When I run gmake, I get some Undefined symbols (See below). Thanks for your suggestions.

...
CCLD save-pixbuf.la
CXXLD exr-load.la
CXXLD exr-save.la
CCLD sdl-display.la
CCLD ppm-load.la
CCLD ppm-save.la
CCLD rgbe-load.la
CCLD rgbe-save.la
gmake[3]: Leaving directory
`/home/brandon/Download/gegl-0.2.0/operations/external' gmake[3]: Entering directory `/home/brandon/Download/gegl-0.2.0/operations' gmake[3]: Nothing to be done for `all-am'. gmake[3]: Leaving directory `/home/brandon/Download/gegl-0.2.0/operations' gmake[2]: Leaving directory `/home/brandon/Download/gegl-0.2.0/operations' Making all in bin
gmake[2]: Entering directory `/home/brandon/Download/gegl-0.2.0/bin' CC gegl.o
CC gegl-path-smooth.o
CCLD gegl
Undefined first referenced symbol in file babl_format_get_bytes_per_pixel ../gegl/.libs/libgegl-0.2.so babl_process ../gegl/.libs/libgegl-0.2.so babl_ticks ../gegl/.libs/libgegl-0.2.so babl_get_name ../gegl/.libs/libgegl-0.2.so babl_format ../gegl/.libs/libgegl-0.2.so babl_format_get_n_components ../gegl/.libs/libgegl-0.2.so babl_exit ../gegl/.libs/libgegl-0.2.so babl_init ../gegl/.libs/libgegl-0.2.so babl_fish ../gegl/.libs/libgegl-0.2.so babl_type ../gegl/.libs/libgegl-0.2.so babl_format_get_type ../gegl/.libs/libgegl-0.2.so babl_backtrack ../gegl/.libs/libgegl-0.2.so ld: fatal: symbol referencing errors. No output written to .libs/gegl collect2: ld returned 1 exit status
gmake[2]: *** [gegl] Error 1
gmake[2]: Leaving directory `/home/brandon/Download/gegl-0.2.0/bin' gmake[1]: *** [all-recursive] Error 1 gmake[1]: Leaving directory `/home/brandon/Download/gegl-0.2.0' gmake: *** [all] Error 2

Brandon Barker Phone: (607) 527-0665
brandon.barker@gmail.com
http://brandon.barker.googlepages.com/home

rassahah@googlemail.com
2012-05-12 16:39:15 UTC (almost 2 years ago)

Problem building on Solaris 11

Brandon Barker wrote:

Hello,

I'm trying to build gegl 0.2.0 on Solaris 11, with the following configuration options (note that I just build babl 0.1.10 and installed it in /usr/local):
CFLAGS="-I/usr/local/include" CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib" BABL_CFLAGS="-I/usr/local/include/babl-0.1" BABL_LIBS="-L/usr/local/lib/babl-0.1" ./configure echo $PATH
/usr/local/bin:/usr/bin:/bin

When I run gmake, I get some Undefined symbols (See below). Thanks for your suggestions.

You could try to actually include the babl-library in your BABL_LIBS, something like this:

... BABL_LIBS="-L/usr/local/lib/babl-0.1 -lbabl-0.1" ./configure

wbr - Rasmus