Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

XP SP3 requirement?

This discussion is connected to the gimp-developer-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

5 of 5 messages available
Toggle history

Please log in to manage your subscriptions.

XP SP3 requirement? Jeremy Morton 06 May 23:00
XP SP3 requirement? Jeremy Morton 07 May 13:45
  XP SP3 requirement? Jernej Simončič 07 May 17:27
   XP SP3 requirement? Jeremy Morton 09 May 10:05
   XP SP3 requirement? Jeremy Morton 09 May 16:44
Jeremy Morton
2012-05-06 23:00:30 UTC (almost 2 years ago)

XP SP3 requirement?

Jernej,

I run XP SP2 on some machines. My vote is also to support SP2. Why is SP2 unsupported, can't you fire up a VM with it on or something? At least provide 2 separate installers, with SP2 and SP3 requirements...

Jeremy Morton
2012-05-07 13:45:13 UTC (almost 2 years ago)

XP SP3 requirement?

Jernej,

The "GTK+ and GIMP installers for Windows" project is listed as GPL-licensed on Sourceforge, but I can't seem to find the source files used to make the latest GIMP-2.8 installer. Could you tell me where I can get them? For example, where the latest Inno Setup ISS script is?

Jernej Simončič
2012-05-07 17:27:06 UTC (almost 2 years ago)

XP SP3 requirement?

On Monday, May 7, 2012, 15:45:13, Jeremy Morton wrote:

The "GTK+ and GIMP installers for Windows" project is listed as GPL-licensed on Sourceforge, but I can't seem to find the source files used to make the latest GIMP-2.8 installer. Could you tell me where I can get them? For example, where the latest Inno Setup ISS script is?

Oops, I forgot to upload the new script - it's now up (though the only changes from the 2.7.4 script are check for SSE and cleanup of a few obsolete plugins from 2.6).

Jeremy Morton
2012-05-09 10:05:08 UTC (almost 2 years ago)

XP SP3 requirement?

On 07/05/2012 18:27, Jernej Simončič wrote:

On Monday, May 7, 2012, 15:45:13, Jeremy Morton wrote:

The "GTK+ and GIMP installers for Windows" project is listed as GPL-licensed on Sourceforge, but I can't seem to find the source files used to make the latest GIMP-2.8 installer. Could you tell me where I can get them? For example, where the latest Inno Setup ISS script is?

Oops, I forgot to upload the new script - it's now up (though the only changes from the 2.7.4 script are check for SSE and cleanup of a few obsolete plugins from 2.6).

... and also, presumably, this:

MinVersion=0,5.01sp3 //MinVersion=0,5.0

Jeremy Morton
2012-05-09 16:44:33 UTC (almost 2 years ago)

XP SP3 requirement?

I changed the registry entry following registry entry on my machine to fake SP3 being installed:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows] "CSDVersion"=dword:00000300

The setup ran fine and GIMP 2.8.0 runs fine. I really think the Windows installer should not refuse to install on SP2, and at most should popup a 'not supported' warning. It's pointless to put a barricade in place because of a registry entry.