Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

How to get GIMP 2.8.0 (Windows)

This download is obsolete. You can find a list of current downloads on our download page.
Product:GIMP
Version:2.8.0
Platform:Windows
Hosted by:sourceforge.net
URL:http://sourceforge.net/projects/gimp-win/files/GIMP%20%2B%20GTK%2B%20%28stable%20release%29/GIMP%202.8.0/gimp-2.8.0-setup.exe/download

Comments

Post your own comments, questions or hints here. The author and other users will see your posting and can reply to it.

Of course, you can also ask in the chat.

Subscription management

Please log in to manage your subscriptions.

*

As a registered user, you can rate articles and comments, attach files to comments, subscribe to topics and you don't need to solve CAPTCHAs anymore.

*…optional

Carl
over 1 year ago

When I click on open an image, gimp gives me the following error:
"there is no disk in the station. Place a medium in station \Device\Harddisk1\DR1.
I can ignore, continue or retry but all the buttons are looping this error, even the X to close the message.

How can I prevent that error please ?

I already removed the whole programm, rebooted and reinstalled but with no difference.

devvv member for over 7 years devvv 1390 comments
over 1 year ago

Is this bug reproducible?

Sleepingbeautiie member for over 1 year Sleepingbeautiie 1 comment
over 1 year ago

I got the same problem as "rsteinmetz70112". Ugh. What the hell is wrong with it... ene...

youchaib
over 1 year ago

i found this bug when i switched to the arabic language

when jumping to the next line the cursor doesn't return at the beginning of the line and the text moves to the right
and when it reaches the begining the first line moves to the left

http://www.youtube.com/embed/lcm9MjfVMkM

devvv member for over 7 years devvv 1390 comments
over 1 year ago

ender/jernej seems to have some problems with building a well working version of GIMP. but first the developers need to release a 2.8.2 tarball... I think they are also overwhelmed with the amount of reported bugs so that the motivation is not on a super-high level currently

Lyle member for about 2 years Lyle 70 comments
over 1 year ago

Yeah; a lot of them have been patched in beta builds (2.8.1; unofficial). Still, not sure why such a delay for 2.8.2; just don't make sense why they are waiting since it's prime time to release it I believe. But I already stated this more then once already; guess I need to learn patience. lol

:)

ilias
over 1 year ago

143 bugs found in gimp 2.8 for windows os

https://bugzilla.gnome.org/buglist.cgi?quicksearch=product%3A%22GIMP%22+os%3A%22Wind%22

ilias
over 1 year ago

i found :
gimp-2.6.12-i686-setup.exe
gimp-2.6.12-i686-setup-1.exe
gimp-2.6.12-i686-setup-2.exe

what is the diference between all these versions
and for what will we need this file:
script-fu-ws2.patch

ilias
over 1 year ago

gimp 2.8 in windows xp sp3 is slow and the new text tool is a disaster i will move to gimp 2.6

flumpo member for almost 2 years flumpo 1 comment
almost 2 years ago

I can't open NEF files. This has just started to happen. in the last couple of days. Before that I could open them with no problem.
Any ideas?

Mishelle
almost 2 years ago

I don't have start up issue (except that it's bloody slow), I don't have a zlib1.dll file in my system32 folder 9only two copies for games I sometimes play). What my problem is is loading my brushes. 2.8 has two folders for brushes and they don't seem to load, the program shuts down. Where you put the abr brushes, the folder is called gimp obsolete files. Does this mean I can't use my old brushes? If so, this sucks. Please advise. Thank you.

Joshua Carlos
almost 2 years ago

into the umbra

rsteinmetz70112
almost 2 years ago

I am having the same problem Mike 52_08 has. Gimp will start but after a few minutes it halts with the same error.

"Program: C:\Program Files\GIMP2\bin\gimp2.8exe
This applicationhas requeseted Runtime to terminate in an unusual way"

I have tried 3 different builds of GiMP 2.89 with the same result.

Fatesrider
almost 2 years ago

My problem with Gimp 2.8 is that it's SLOW. I didn't get beyond that in my evaluation.

It's four times larger than Gimp 2.6 last version, but that's not an issue. I run 2 GB 1066 DDR2 RAM in a Winx XP Pro, SP3 machine with a 3.0 GHz Core2 Duo processor. Not exactly state of the art, but no slouch in the processing department.

After installing and running GIMP 2.8 without any problems, I opened an old project with about a dozen layers, one of which was a template I used to size a project for print. When switching from hidden to visible, it took about 30 seconds to load, a row at a time. In 2.6, it didn't take any noticeable time at all.

I've tried GIMP 2.8 for Windows three times, but it has not been updated since the 2.8 for Linux came out. Since I use some Windows-only programs to create part of my GIMP projects, switching back and forth between them, having to use two operating systems to get my projects done isn't practical. There were other problems with layers and layer selections before that I didn't notice last time I tried GIMP, however I've uninstalled 2.8 and have gone back to 2.6.12 since it addresses all of my needs, even if it isn't as "new" as 2.8.

If they ever update 2.8 for Windows to fix the speed and display issues, I'll check it out. But until that download file size changes and the hash remains the same, I'll wait for the next iteration of GIMP. 2.8 right now is a show-stopper, literally.

sky
almost 2 years ago

did as Durga Prasad suggested
(Renamed C:\Windows\System32\zlib1.dll to zlib1-bkup.dll,
it works!!
thanks you so much

Mike52_08
almost 2 years ago

Every time I try to use V2.8 running on a laptop mwith Windows XP Profssional, I get a Runtime Error message:
"Program: C:\Program Files\GIMP2\bin\gimp2.8exe
This applicationhas requeseted Runtime to terminate in an unusual way"

I have tried the Microsoft "Hot Fix" for this error only to be told that I already have alater version of the file(s) concerned. My version of XP Pro is fully up to date withte relevant patches and I have updated my copy of Visual. C++ all to no avail

Mike
almost 2 years ago

Win7 - Gimp 2.8 - When trying to install from setup file, I receive an error window with the message
" The Setup files are corrupted, please obtain a new copy of the program". I obtain and same issue.

Phatchaz
almost 2 years ago

Win7 64 - same zlib1.dll error on install, not fixed by renaming zlib1 in system folder. Decided to revert to Gimp 2.6.11 and live without single window mode till this issue is addressed.

Pantella
almost 2 years ago

Hozec's right. I also have win7 and can't find the zlib1.dll (I even deleted my bro's skyrim zlib) I tried renaming it but nothing happened. I also deleted all the Gimp 2.6 but it's still not working. Anyone help?

When I downloaded Gimp 2.8 in a separated laptop it worked perfectly. But when I downloaded it to my comp (which had the old version) It didn't ever worked.

hozec
almost 2 years ago

zlib1.dll not even present in the windows folder on win7...found several copies throught in diferent app folders...no help in renaming/deleting everything...
when tried to copy from GIMP bin folder to C:\Windows\system32 it disappears after trying to run the gimp from the windows system folder...

Durga Prasad
almost 2 years ago

Renamed C:\Windows\System32\zlib1.dll to zlib1-bkup.dll

Then Gimp 2.8 starts fine on Win7.

a Gimp
almost 2 years ago

Renaming zlib1.dll fixed my numerous plugin .dll entry point errors, too.
Thanks!

Mark Leffler
almost 2 years ago

For everyone having the "procedure entry point" issues, the old zlib1 is definitely the culprit (per Tony Cook below). Renamed it to "*.old", reinstall, working perfectly.

Tony Cook
almost 2 years ago

I had this problem too. The cause turned out to be an old copy of zlib1 in my systems folder. Cleaned it out, re-installed, up and working.

George Gerhold
almost 2 years ago

The histogram does not show colors as the tutorial indicates. Is hep 2.6 the right version, or is there a help 2.8?

Tinu
almost 2 years ago

Update: "libgdk-win32" was in system folder "C:\Windows" - its the wrong place - I renamed it to *.bak - and Gimp 2.8 is now running!

Tinu
almost 2 years ago

On Windows 7 gimp 2.8 doesn't run - lot of "The procedure entry point" messages. After a "clean install" same problem. Giving up...

hozec
almost 2 years ago

win 7 pro:
"The procedure entry point gtk_box_new could not be located in the dynamic link library libgimpwidgets-2.0-0.dll"
popup window with this error appears for all the EXE plugins in the folder "..\GIMP 2.8\lib\gimp\2.0\plug-ins"
I had the same problem for the 2.8 RC1 version...
tried to install in diferent directory, didn' t help...
tried to uninstall, cleared registers, clean install - the problem persists...
last stable 2.6 version works fine...

friesenlyle member for about 3 years friesenlyle 1 comment
almost 2 years ago

Any Idea why the paint dynamics editor not working. Options are all greyed out. (v2.8) Dynamic presets all work. Matrix all greyed out.....

SEBASTIAN
almost 2 years ago

DE MAS

SEBASTIAN
almost 2 years ago

YUPII!

cad
almost 2 years ago

Win 7. Cannot open GIMP 2.8.0. Error "The procedure entry point gzdirect could not be located in the dynamic link library zlib1.dll". Help?

devvv member for over 7 years devvv 1390 comments
almost 2 years ago

misrak: service pack 3 or higher is required for win xp!

misrak
almost 2 years ago

HELP
my comp. is XP version 2002 with service pack 2 but when I tried to install GIMP2.8 I got a message saying -This version of GIMP requires with service pack 2, or a new version of window. Then I went to the latest version but I got another message- .exe-entry point not found and ...entry point gzdirect could not be located in the dynamic link library zlib1.dll. What is all these?

youchaib25
almost 2 years ago

thank you devvv

i did not pay attention to the notification in gimp's site web

i will move to the sp3

i hope that the next gimp's versions will not require windows7 to run

devvv member for over 7 years devvv 1390 comments
almost 2 years ago

Settings should not be deleted if you uninstall, I guess. You can try to manually delete/rename your settings folder in /Users//.gimp-2.8 and try what it does when you startup again. First startup may bring you a white image, that takes about 1 min to create everything. Did you restart your PC after install?

serr8d
almost 2 years ago

Un-runnable. Over 1 hundred errors on startup, for the most part "Entry Point Not Found" errors. For example: "The procedure entry point gtk_box_new could not be located in the dynamic link library libgimpwidgets-2.0-0.dll". Literally, at least a hundred of these. After the initial startup, no files would open. Two .dll files were mentioned.

Sadly, it uninstalled my previous version of GIMP. And possibly all my settings.

I'll uninstall and reinstall, but this, so far, is a mess.

devvv member for over 7 years devvv 1390 comments
almost 2 years ago

you need service pack 3 or higher!

youchaib25
almost 2 years ago

i downloaded gimp 2.8 from the official site web and when i try to install it i got an error:
this version of gimp requires windows xp with service pack 2, or a newer version of windows.

but i have windows xp service pack2 2002 installed in my computer.

please help me.