Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Last stable 2.6 release: 2.6.12 has arrived

By at 2012-02-03 01:47:51 UTC, last updated almost 3 years ago. CC BY-NC License

There is one last bug fix release in the stable GIMP 2.6 series before the highly anticipated GIMP 2.8.

Lots of reported problems have been fixed:

Changes from 2.6.11 to 2.6.12:

These bugs were fixed:

  • 627328 – GIMP 2.6.10 segfaults when CTRL-left click on a layer mask
  • 631885 – GIMP fails to import a path from SVG
  • 631728 – Crash or Gtk-CRITICAL on File→Open
  • 641259 – [abrt] gimp-2:2.6.11-1.fc14: py-slice.py:172:slice:TypeError: integer argument expected, got float
  • 640219 – gimp(1) manpage fixes
  • 640612 – Sample Colorize does not function non-interactively
  • 646947 – file-pdf-load: Don’t use deprecated API
  • 639203 – file-psp: fix for bogus input data
  • 639203 – Fixes for some buffer overflow problems
  • 652280 – Guard against crash due to quitting while DND is processed
  • 660305 – fails to build with -Werror=format-security
  • 623045 – script-fu: make server IPv6 aware

and many more!

Also there have been several translation updates. Binary files are not yet available but will follow soon for sure. Meanwhile please stick with the source code we inlcuded in our downloads section

There is no other news on a release date but it is the most important thing for the developers to get GIMP 2.8 out as soon as possible!

Comments

Post your own comments, questions or hints here. The author and other users will see your posting and can reply to it.

Of course, you can also ask in the chat.

Subscription management

Please log in to manage your subscriptions.

User rating

This topic (Last stable 2.6 release: 2.6.12 has arrived) has been rated 4.0/5.0.

*

As a registered user, you can rate articles and comments, attach files to comments, subscribe to topics and you don't need to solve CAPTCHAs anymore.

*…optional

devvv member for over 8 years devvv 1436 comments
almost 3 years ago

there was a second and 3rd release of 2.6.12. we included the latest one now in the downloads section! should work fine now

Steve
almost 3 years ago

2.6.12 crashes on startup in windows xp. 2.6.11 works fine.

unhammer member for over 5 years unhammer 24 comments
almost 3 years ago

bah just use 2.7.4 (or 2.7.5 on Windows)

radek
almost 3 years ago

I still believe that 2.8 will be released this year. ;)

Difydave member for over 4 years Difydave 11 comments rated this topic with 4/5
almost 3 years ago

That's great news. Thanks developers.

What's happening with the release of 2.8 now?

billn member for about 4 years billn 14 comments rated this topic with 4/5
almost 3 years ago

I gave up on 2.8 being released years ago.