Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

gimp 2.10.4 midi not working

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

3 of 3 messages available
Toggle history

Please log in to manage your subscriptions.

gimp 2.10.4 midi not working patrick via gimp-user-list 14 Aug 03:08
  gimp 2.10.4 midi not working Jehan Pagès via gimp-user-list 15 Aug 17:20
  gimp 2.10.4 midi not working Kevin Cozens 16 Aug 15:20
patrick via gimp-user-list
2018-08-14 03:08:38 UTC (3 months ago)

gimp 2.10.4 midi not working

When trying to compile on Raspbian (debian) Stretch, I am not able to install all the deps:

- Error: missing dependency babl >= 0.1.52 - Error: missing dependency gegl-0.4 >= 0.4.4 - Error: missing dependency glib >= 2.54.2 *** Test for GLIB failed
- Error: missing dependency gegl
*** Could not find native gegl executable in your PATH. - Error: missing dependency fontconfig >= 2.12.4 - Error: missing dependency gexiv2 >= 0.10.6 - Error: missing dependency poppler-glib >= 0.44.0

glib >= 2.54.2 is really a show stopper on this distribution afaik.

About the midi problem with the flatpak, it is kind of documented here, so it doesn't look too good for me: https://github.com/flatpak/flatpak/issues/12

Not an expert on the subject, but when using snap you can add permission using interfaces:
https://docs.snapcraft.io/reference/interfaces

So the question is: anyone using gimp 2.10.4 with midi support on rpi3? Thanks

Jehan Pagès via gimp-user-list
2018-08-15 17:20:05 UTC (3 months ago)

gimp 2.10.4 midi not working

Hi!

On Tue, Aug 14, 2018 at 5:09 AM patrick via gimp-user-list < gimp-user-list@gnome.org> wrote:

When trying to compile on Raspbian (debian) Stretch, I am not able to install all the deps:

- Error: missing dependency babl >= 0.1.52 - Error: missing dependency gegl-0.4 >= 0.4.4 - Error: missing dependency glib >= 2.54.2 *** Test for GLIB failed
- Error: missing dependency gegl
*** Could not find native gegl executable in your PATH. - Error: missing dependency fontconfig >= 2.12.4 - Error: missing dependency gexiv2 >= 0.10.6 - Error: missing dependency poppler-glib >= 0.44.0

glib >= 2.54.2 is really a show stopper on this distribution afaik.

I would indeed not install a glib different from the distribution one

system-wide (on any distribution), since it is low level and widely used (and could break other programs), but it is easy to install it in a custom prefix and have GIMP only use this version.

Unless you mean that it is impossible to build glib 2.54.2 on Raspbian. In this case, I have no idea (but this may be the occasion to fix whatever needs to be).

About the midi problem with the flatpak, it is kind of documented here, so it doesn't look too good for me: https://github.com/flatpak/flatpak/issues/12

Yes the MIDI support is not built in GIMP on Flatpak. And you should not expect this to work any time soon (I mean, it may happen any day, who knows?! But it is quite some work and it doesn't look like anyone is really interested into this).

I did not answer on this in my first email as I was unsure you were really asking about this specific feature (you did not ask about this in the body of the email, only as a short mention in the title). :-)

Not an expert on the subject, but when using snap you can add permission using interfaces:
https://docs.snapcraft.io/reference/interfaces

This is the same thing for Flatpak, but someone needs to implement the

said permission first.
In the case of this specific feature, it would require someone to implement the said portal (possibly several times, as it may depend on the desktop for instance; don't know if this is the case here), then someone to re-implement the feature in GIMP instead of using libudev (which is how we currently implement this feature, but this won't ever work; libudev won't likely ever be usable in a Flatpak sandbox).

So the question is: anyone using gimp 2.10.4 with midi support on rpi3?

You won't find anyone, this is currently not possible.

If having this feature is a blocker to you, then yes, you have to install GIMP some other way, either by building it yourself or waiting for the distribution to get a GIMP 2.10 package; I saw that Debian Testing just got GIMP 2.10.2. This should reach Raspbian at some point. :-)

Jehan

Thanks
_______________________________________________ gimp-user-list mailing list
List address: gimp-user-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list List archives: https://mail.gnome.org/archives/gimp-user-list

ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
Kevin Cozens
2018-08-16 15:20:54 UTC (3 months ago)

gimp 2.10.4 midi not working

On 2018-08-13 11:08 PM, patrick via gimp-user-list wrote:

When trying to compile on Raspbian (debian) Stretch, I am not able to install all the deps:

- Error: missing dependency babl >= 0.1.52 - Error: missing dependency gegl-0.4 >= 0.4.4 - Error: missing dependency glib >= 2.54.2 *** Test for GLIB failed
- Error: missing dependency gegl
*** Could not find native gegl executable in your PATH. - Error: missing dependency fontconfig >= 2.12.4 - Error: missing dependency gexiv2 >= 0.10.6 - Error: missing dependency poppler-glib >= 0.44.0

glib >= 2.54.2 is really a show stopper on this distribution afaik.

It isn't a show stopper. You can install GIMP and its dependencies to a directory within you user account and run it from there. You set PREFIX to the be the path to the private directory then use that include a reference to the path in both LD_LIBRARY_PATH and PKG_CONFIG_PATH.

Cheers!

Kevin.

http://www.ve3syb.ca/               | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
                                     | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include      |             --Chris Hardwick