Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Compile from GIT

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

3 of 3 messages available
Toggle history

Please log in to manage your subscriptions.

Compile from GIT dafrasaga 20 Jan 16:54
  Compile from GIT Ken Moffat via gimp-user-list 20 Jan 20:08
   Compile from GIT dafrasaga 23 Jan 08:45
2018-01-20 16:54:28 UTC (about 1 month ago)
postings
2
contact
Send private message

Compile from GIT

Hi All,
I'm in compiling from GIT but after installed all dependances,babl,gegl,mypaint.brushes in /opt/gimp-master I get this error when make in Gimp:

Making all in . make[4]: Entering directory '/root/git/gimp-master/gimp/app' CCLD gimp-2.9
CCLD gimp-console-2.9
core/libappcore.a(gimpimage-undo.o): In function `gimp_image_undo_push': /root/git/gimp-master/gimp/app/core/gimpimage-undo.c:402: undefined reference to `g_object_new_with_properties' collect2: error: ld returned 1 exit status

I think to understand gimp needs g_object_new_with_properties function which I have into /opt/gimp-master/lib/libgobject-2.0.so.0.5501.0. It seems it point to another libgobject I have in /usr/lib64 from my distro (Slackware 14.2). In Config.log all libs with -lgobject-2.0 have -L/opt/gimp-master/lib as path

I'm very noob about compiling.. could someone help me??

Cheers Gabriele

Ken Moffat via gimp-user-list
2018-01-20 20:08:25 UTC (about 1 month ago)

Compile from GIT

On Sat, Jan 20, 2018 at 05:54:28PM +0100, dafrasaga wrote:

[ Cc:'ing as well as the list, because mail from gimp-users is intermittent - subscribing to the list seems much more reliable ]

Hi All,
I'm in compiling from GIT but after installed all dependances,babl,gegl,mypaint.brushes in /opt/gimp-master I get this error when make in Gimp:

Making all in .
make[4]: Entering directory '/root/git/gimp-master/gimp/app' CCLD gimp-2.9
CCLD gimp-console-2.9
core/libappcore.a(gimpimage-undo.o): In function `gimp_image_undo_push': /root/git/gimp-master/gimp/app/core/gimpimage-undo.c:402: undefined reference to `g_object_new_with_properties'
collect2: error: ld returned 1 exit status

I think to understand gimp needs g_object_new_with_properties function which I have into
/opt/gimp-master/lib/libgobject-2.0.so.0.5501.0. It seems it point to another libgobject I have in /usr/lib64 from my distro (Slackware 14.2).
In Config.log all libs with -lgobject-2.0 have -L/opt/gimp-master/lib as path

I'm very noob about compiling.. could someone help me??

I've never tried building the gimp in /opt, but two suggestions:

1. Ensure /opt/gimp-master/lib is mentioned in /etc/ld.so.conf, and then (even if it is already mentioned there) run ldconfig - some libraries occasionally do not run ldconfig.

2. Ensure that PKG_CONFIG_PATH is correct: export PKG_CONFIG_PATH=/opt/gimp-master/lib/pkgconfig:/opt/gimp-master/share/pkgconfig:$PKG_CONFIG_PATH

ĸen

Truth, in front of her huge walk-in wardrobe, selected black leather
boots with stiletto heels for such a barefaced truth.
                                     - Unseen Academicals
2018-01-23 08:45:17 UTC (about 1 month ago)
postings
2
contact
Send private message

Compile from GIT

[ Cc:'ing as well as the list, because mail from gimp-users is intermittent - subscribing to the list seems much more reliable ] I've never tried building the gimp in /opt, but two suggestions:

1. Ensure /opt/gimp-master/lib is mentioned in /etc/ld.so.conf, and then (even if it is already mentioned there) run ldconfig - some libraries occasionally do not run ldconfig.

2. Ensure that PKG_CONFIG_PATH is correct: export
PKG_CONFIG_PATH=/opt/gimp-master/lib/pkgconfig:/opt/gimp-master/share/pkgconfig:$PKG_CONFIG_PATH

ĸen

Hi Ken,
thanks for the hint but it didn' work... I investigated more and I found my libgegl points to /usr /lib64 instead /opt/gimp-master/lib I think because is hardcoded rpath with /usr/lib64 whwre I have glib 2.46 where there isn't function g_object_new_with_properties I ran configure with --disable-rpath but nothing is changed. I ran configure with LDFLAGS="-L/opt/gimp-master/lib" but nothing is changed.

hints??