Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Back to gimp 2.6 (finding a debian repository or compiling ?)

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

3 of 3 messages available
Toggle history

Please log in to manage your subscriptions.

Back to gimp 2.6 (finding a debian repository or compiling ?) minhsien0330 16 Jun 02:24
  Back to gimp 2.6 (finding a debian repository or compiling ?) minhsien0330 18 Jun 01:26
   Back to gimp 2.6 (finding a debian repository or compiling ?) Michael Schumacher 18 Jun 18:30
minhsien0330
2012-06-16 02:24:22 UTC (over 2 years ago)

Back to gimp 2.6 (finding a debian repository or compiling ?)

Dear all:
The new save/export behavior of Gimp 2.8 is REALLY hard to adapt for me when dealing with non-XCF images.
I want to downgrade to 2.6, but Debian (both wheezy and sid) had already upgraded 2.6 to 2.8.
Do any Debian user here know where to find a debian repository that provide packages of gimp-2.6 (for wheezy/sid)? Or anybody know how to compile 2.6 on Debian (wheezy/Sid) step by step?

Thanks a lot~

Best Regards,

minhsien0330
2012-06-18 01:26:16 UTC (over 2 years ago)

Back to gimp 2.6 (finding a debian repository or compiling ?)

Dear all:
I tried to compile gimp, but a error occured (I post it below). Do you know how to deal with this?
Thanks a lot.

Regards,

--- for image in cursor-bad.png cursor-color-picker.png cursor-corner-top-left.png cursor-corner-top-right.png cursor-corner-bottom-left.png cursor-corner-bottom-right.png cursor-crosshair.png cursor-crosshair-small.png cursor-mouse.png cursor-move.png cursor-none.png cursor-side-top.png cursor-side-left.png cursor-side-right.png cursor-side-bottom.png cursor-zoom.png modifier-anchor.png modifier-bad.png modifier-background.png modifier-control.png modifier-foreground.png modifier-intersect.png modifier-join.png modifier-minus.png modifier-move.png modifier-pattern.png modifier-plus.png modifier-resize.png modifier-select.png tool-airbrush.png tool-blend.png tool-blur.png tool-bucket-fill.png tool-burn.png tool-clone.png tool-color-picker.png tool-crop.png tool-dodge.png tool-ellipse-select.png tool-eraser.png tool-flip-horizontal.png tool-flip-vertical.png tool-free-select.png tool-fuzzy-select.png tool-hand.png tool-heal.png tool-ink.png tool-iscissors.png tool-measure.png tool-move.png tool-paintbrush.png tool-paths.png tool-paths-anchor.png tool-paths-control.png tool-paths-segment.png tool-pencil.png tool-perspective.png tool-polygon-select.png tool-rect-select.png tool-resize.png tool-rotate.png tool-shear.png tool-smudge.png tool-text.png tool-zoom.png; do \ echo $image | \
sed -e 's|.*/||' -e 's|-|_|g' -e 's|\.png$||' >> tool-cursors.list; \
echo " ./$image" >> tool-cursors.list; \ done )
/usr/bin/gdk-pixbuf-csource --raw --build-list `cat tool-cursors.list` > gimp-tool-cursors.h
failed to load "./cursor-bad.png": Couldn't recognize the image file format for file './cursor-bad.png'
make[2]: *** [gimp-tool-cursors.h] Error 1 make[2]: Leaving directory `/mnt/store/Linux/gimp-2.6.11/cursors' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/mnt/store/Linux/gimp-2.6.11' make: *** [all] Error 2

Michael Schumacher
2012-06-18 18:30:19 UTC (over 2 years ago)

Back to gimp 2.6 (finding a debian repository or compiling ?)

On 18.06.2012 03:26, minhsien0330 wrote:

Dear all:
I tried to compile gimp, but a error occured (I post it below).

failed to load "./cursor-bad.png": Couldn't recognize the image file format for file './cursor-bad.png'

What is this file's file format? The utility file should tell.

make[1]: Leaving directory `/mnt/store/Linux/gimp-2.6.11'

Is there a reason why you try to build 2.6.11 and not the latest release of the old 2.6 branch, 2.6.12?

Regards, Michael