Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

python support (

This discussion is connected to the gimp-user-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

7 of 9 messages available
Toggle history

Please log in to manage your subscriptions.

python support Adonj Adonj 14 Oct 04:30
mailman.225250.1223954742.1... 07 Oct 20:19
  python support Alchemie foto\\grafiche 14 Oct 17:48
   python support Adonj Adonj 14 Oct 22:33
   python support Alec Burgess 15 Oct 07:13
mailman.225704.1224056387.1... 07 Oct 20:19
  python support Alchemie foto\\grafiche 15 Oct 15:37
  python support ( Alchemie foto\\grafiche 15 Oct 17:02
   python support ( Michael Schumacher 16 Oct 19:00
Adonj Adonj
2008-10-14 04:30:44 UTC (almost 6 years ago)

python support

I'm running gimp 2.6.1 on windows xp, I have a couple of python plugins in my ...\.gimp-2.6\plug-ins directory, yet they don't appear in the menu. Do I need to install some gimp python support, or what could the reason be? Thanks.

__________________

Alchemie foto\\grafiche
2008-10-14 17:48:28 UTC (almost 6 years ago)

python support

I'm running gimp 2.6.1 on windows xp, I have a couple of python plugins
in my ...\.gimp-2.6\plug-ins directory, yet they don't appear in the menu. Do I
need to install some gimp python support, or what could the reason be?
Thanks.

Reason is that python support in Windows version of Gimp is disabled by default. Is possible enable it, for that is needed Unistall gimp, install Python libraries (not only Python ) and then reinstall Gimp with the "custom" option, and in the following dialog check the "python" checkbox.

But do not worry to make it easier i grouped all that is needed including Python in a single pack, with a almost idiot proof " how to install"

Pack is here http://photocomix-resources.deviantart.com/art/Gimp-Python-support-easier-74889017 i done for Gimp 2.4 but i believe is still updated,anyway for me still works with last gimp 2.6.1 again how to is included, you can't miss that text file is very clearly labeled

even more information on installing/running python on gimp windows are here http://www.gimptalk.com/forum/python-and-gimp-t25587.html

Scopri il blog di Yahoo! Mail: Trucchi, novità e scrivi la tua opinione. http://www.ymailblogit.com/blog

Adonj Adonj
2008-10-14 22:33:02 UTC (almost 6 years ago)

python support

Thanks, that helped a lot!> Date: Tue, 14 Oct 2008 15:48:28 +0000> From: fotocomics@yahoo.it> To: gimp-user@lists.XCF.Berkeley.EDU> Subject: Re: [Gimp-user] python support> > > > I'm running gimp 2.6.1 on windows xp, I have a couple> > of python plugins > > in my ...\.gimp-2.6\plug-ins directory, yet they> > don't appear in the menu. Do I> > need to install some gimp python support, or what could the> > reason be?> > Thanks.> > Reason is that python support in Windows version of Gimp is disabled by default.> Is possible enable it, for that is needed Unistall gimp, install Python libraries (not only Python ) and then reinstall Gimp with the "custom" option, and in the following dialog check the "python" checkbox.> > But do not worry to make it easier i grouped all that is needed including Python in a single pack, with a almost idiot proof " how to install"> > > Pack is here http://photocomix-resources.deviantart.com/art/Gimp-Python-support-easier-74889017> i done for Gimp 2.4 but i believe is still updated,anyway for me still works with last gimp 2.6.1> again how to is included, you can't miss that text file is very clearly labeled> > even more information on installing/running python on gimp windows are here> http://www.gimptalk.com/forum/python-and-gimp-t25587.html> > > > Scopri il blog di Yahoo! Mail:> Trucchi, novità e scrivi la tua opinione.> http://www.ymailblogit.com/blog> _______________________________________________> Gimp-user mailing list> Gimp-user@lists.XCF.Berkeley.EDU> https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user __________________

Alec Burgess
2008-10-15 07:13:34 UTC (almost 6 years ago)

python support

Alchemie foto\grafiche (fotocomics@yahoo.it) wrote (in part) (on 2008-10-14 at 11:48):

I'm running gimp 2.6.1 on windows xp, I have a couple

> > of python plugins
> > in my ...\.gimp-2.6\plug-ins directory, yet they > > don't appear in the menu. Do I
> > need to install some gimp python support, or what could the > > reason be?
> > Thanks.

Reason is that python support in Windows version of Gimp is disabled by default.
Is possible enable it, for that is needed Unistall gimp, install Python libraries (not only Python ) and then reinstall Gimp with the "custom" option, and in the following dialog check the "python" checkbox.

But do not worry to make it easier i grouped all that is needed including Python in a single pack, with a almost idiot proof " how to install"

Pack is here

http://photocomix-resources.deviantart.com/art/Gimp-Python-support-easier-74889017

i done for Gimp 2.4 but i believe is still updated,anyway for me still works with last gimp 2.6.1
again how to is included, you can't miss that text file is very clearly labeled

even more information on installing/running python on gimp windows are here
http://www.gimptalk.com/forum/python-and-gimp-t25587.html

@fotocomix - I found the above reference a couple of days ago (I think by googling [python gimp plugin]. Just thought I'd comment on the need for reboots you stressed in your "IDIOTS NEVER READ THIS". Not sure if anything has changed in GIMP between 2.4 and 2.6.1. I already had Python25 and pygtk-2.12.1-2 but not the other two requirements.

Filters>Python-Fu>Console was NOT showing up.

I think all three of the packages have later versions since you created the ZIP so I got them. With Gimp closed I installed the two I was missing (pycairo-1.4.12-1, pygobject-2.14.1-1) and restarted GIMP. Python-Fu showed up this time :-)

No reboots were necessary.

Alchemie foto\\grafiche
2008-10-15 15:37:55 UTC (almost 6 years ago)

python support

I think all three of the packages have later versions since you created
the ZIP so I got them. With Gimp closed I installed the two I was
missing (pycairo-1.4.12-1, pygobject-2.14.1-1) and restarted GIMP.
Python-Fu showed up this time :-)

Thank Alex for the heads up

I should be automatically notified od changes in that pages but obviously something went wrong

I'm downloading the new versions and i ill update everything at soon possible,and i must find a more reliable service for automatically detect changes on chosen web pages

Scopri il blog di Yahoo! Mail: Trucchi, novità e scrivi la tua opinione. http://www.ymailblogit.com/blog

Alchemie foto\\grafiche
2008-10-15 17:02:21 UTC (almost 6 years ago)

python support (

I think all three of the packages have later versions since you created
the ZIP so I got them. With Gimp closed I installed the two I was
missing (pycairo-1.4.12-1, pygobject-2.14.1-1) and restarted GIMP.
Python-Fu showed up this time :-)

No reboots were necessary.

i just check and all packages have newer version but then some newer versions are incompatible.

as example is required python 2.5 with last python 2.6 Pyobject refuse to install.

so at least for python is required a not updated version

i am busy to install on my pc and see what may be updated maybe only the 3 py libraries

about the need to reboot i stressed the point because apparently solved several cases of failed installation

about reboot i am not sure if the case to remove that advice

2 reboots may be a nuisance but not as be puzzled to failed install, unistall everything,clean up unistall leftover , download again checking the checksum,reinstall. ..and fail again ..again same no Python option to select in Gimp custom install dialog

then even if may be not strictly needed that added reboot steps solved 3 on total of 3 of this cases, after everything else failed to solve.

Scopri il blog di Yahoo! Mail: Trucchi, novità e scrivi la tua opinione. http://www.ymailblogit.com/blog

Michael Schumacher
2008-10-16 19:00:56 UTC (almost 6 years ago)

python support (

Von: "Alchemie foto\\\\grafiche"

i just check and all packages have newer version but then some newer versions are incompatible.

as example is required python 2.5 with last python 2.6 Pyobject refuse to install.

It's not really surprising that a package for Python 2.6 can't be installed to Python 2.5.

Michael