Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

This discussion is connected to the gimp-developer-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

11 of 12 messages available
Toggle history

Please log in to manage your subscriptions.

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 richard brown via gimp-developer-list 11 Jul 13:59
  configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Kevin Cozens 11 Jul 14:16
   903d9b7c-ddd4-9100-7460-fbc... 13 Jul 17:53
    configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Kevin Cozens 13 Jul 17:53
  configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Shlomi Fish 11 Jul 15:38
  configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Owen 12 Jul 02:47
  configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Liam R E Quin 14 Jul 01:40
   configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Kevin Cozens 16 Jul 03:15
   configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Jehan Pagès via gimp-developer-list 24 Jul 10:04
    configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Liam R E Quin 24 Jul 15:24
    configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Kevin Cozens 02 Aug 18:04
     configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7 Jehan Pagès via gimp-developer-list 03 Aug 10:01
richard brown via gimp-developer-list
2018-07-11 13:59:06 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

Hi all,

The latest git pull of 2.99 won't build.  It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Any ideas?

Kevin Cozens
2018-07-11 14:16:11 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On 2018-07-11 09:59 AM, richard brown via gimp-developer-list wrote:

The latest git pull of 2.99 won't build.  It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Last night I discovered this (yet another) new dependency required to compile GIMP. I'm still trying to compile it as my distro only has a 0.5 version of the library. I have no idea why it is needed. When I tried to compile it I find it tries to ocmpile with support for RPM packaging. I don't use RPM packaging on my machine.

Richard, I would have said that you need to installed the -dev package of libappstream-glib installed on your machine except you buit-it yourself. I'm trying to compile it myself but it isn't finding the yaml library even though it is installed. If I get my compile to work I can dig in to the problem.

Cheers!

Kevin.

http://www.ve3syb.ca/               | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
                                     | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include      |             --Chris Hardwick
Shlomi Fish
2018-07-11 15:38:24 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On Wed, 11 Jul 2018 14:59:06 +0100 richard brown via gimp-developer-list wrote:

Hi all,

The latest git pull of 2.99 won't build.  It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Perhaps see https://linux.die.net/man/1/pkg-config - set PKG_CONFIG_PATH

Any ideas?
_______________________________________________ gimp-developer-list mailing list
List address: gimp-developer-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list List archives: https://mail.gnome.org/archives/gimp-developer-list

-----------------------------------------------------------------
Shlomi Fish       http://www.shlomifish.org/
Emma Watson Factoids - http://shlom.in/emwatson-facts

Medusa’s gaze can turn people into stone. Buffy’s gaze can turn Medusa into
stone.
    — http://www.shlomifish.org/humour/bits/facts/Buffy/

Please reply to list if it's a mailing list post - http://shlom.in/reply .
Owen
2018-07-12 02:47:45 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

The latest git pull of 2.99 won't build.  It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Just where is your appstream-glib.pc ?

You might have to alter your share/config.site if you use that, or your search path.

Owen

Kevin Cozens
2018-07-13 17:53:26 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On 2018-07-11 10:47 AM, richard brown wrote:

On 11/07/18 15:16, Kevin Cozens wrote:

On 2018-07-11 09:59 AM, richard brown via gimp-developer-list wrote:

The latest git pull of 2.99 won't build. It gives me the error

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

I think it just needed the rpm stuff for some reason.  I installed rpm (don't use it either).
I had to install a more recent gobject-introspection to get the more recent appstream-glib to build.  And yes, there's a bug with yaml and the meson build system.  see:

https://github.com/ximion/appstream/issues/146

I would add that you need a recent version of meson to get it to build properly too.

I love dependency problems.

Indeed. :P

This is the worse case of dependency problems for GIMP I have had to deal with in quite a while. I need to compile appstream-glib which needed about three other -dev packages. I then hit the yaml issue which required the newer glib-introspection program. Trying to compile that required some other package I don't have. About this point I gave up on trying to build git master branch of GIMP.

If/when I update my distro to Mint 19 I'll try again.

Cheers!

Kevin.

http://www.ve3syb.ca/               | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
                                     | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include      |             --Chris Hardwick
Liam R E Quin
2018-07-14 01:40:07 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On Wed, 2018-07-11 at 14:59 +0100, richard brown via gimp-developer- list wrote:

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

On my system i edited configure to require 0.7.6 (which i have) and it worked.

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Check there's a .pc file in $PREFIX/usr/lib/pkgconfig/ and also that the directory containing it is in your PKG_PATH.

If so, check config.log to see what went wrong...

Liam (slave ankh)

Liam Quin - web slave for https://www.fromoldbooks.org/
with fabulous vintage art and fascinating texts to read.
Click here to have the slave beaten.
Kevin Cozens
2018-07-16 03:15:29 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On 2018-07-13 09:40 PM, Liam R E Quin wrote:

On Wed, 2018-07-11 at 14:59 +0100, richard brown via gimp-developer- list wrote:

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

On my system i edited configure to require 0.7.6 (which i have) and it worked.

I thought about seeing if I could just modify configure to expect an older version of the appstream-glib library. The version available for my distro is 0.5 something which I thought might be too old. I already modified configure to expect older versions of two other dependencies to save me having to build newer versions.

Cheers!

Kevin.

http://www.ve3syb.ca/               | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
                                     | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include      |             --Chris Hardwick
Jehan Pagès via gimp-developer-list
2018-07-24 10:04:28 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

Hi!

On Sat, Jul 14, 2018 at 3:40 AM, Liam R E Quin wrote:

On Wed, 2018-07-11 at 14:59 +0100, richard brown via gimp-developer- list wrote:

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7"

On my system i edited configure to require 0.7.6 (which i have) and it worked.

For the record, I just checked current code and actual minimum dep (relatively to the functions I use from this lib) would be 0.6.7. I could set a lower value, but really the development is barely started on this feature, I will use more API soon so it may go back up soon anyway, and I'm not sure if it is worth just going back and forth on dependency versions.

Note that I originally chose this version 0.7.7 by looking at Debian Testing, which is our base for deciding whether a version can a requirement in the development GIMP.
Also this is development code. It is expected to get bumpy. We even realized this dependency has problems to build on Windows, but it's ok. We are confident that this will improve. This is not the first time (and won't be the last) that we improve projects by using them, and in particular that we make them going cross-platform. :-)

Jehan

Ah, but I have appstream-glib >0.7.7 installed; built it from source and installed it into the prefix I use for gimp.

Check there's a .pc file in $PREFIX/usr/lib/pkgconfig/ and also that the directory containing it is in your PKG_PATH.

If so, check config.log to see what went wrong...

Liam (slave ankh)

-- Liam Quin - web slave for https://www.fromoldbooks.org/ with fabulous vintage art and fascinating texts to read. Click here to have the slave beaten. _______________________________________________ gimp-developer-list mailing list
List address: gimp-developer-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp- developer-list
List archives: https://mail.gnome.org/archives/gimp-developer-list

ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
Liam R E Quin
2018-07-24 15:24:44 UTC (4 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On Tue, 2018-07-24 at 12:04 +0200, Jehan Pagès wrote:

Hi!

On Sat, Jul 14, 2018 at 3:40 AM, Liam R E Quin wrote:

On Wed, 2018-07-11 at 14:59 +0100, richard brown wrote:

"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib

= 0.7.7"

On my system i edited configure to require 0.7.6 (which i have) and it worked.

For the record, I just checked current code and actual minimum dep (relatively to the functions I use from this lib) would be 0.6.7. I could set a lower value, but really the development is barely started on
this feature, I will use more API soon so it may go back up soon anyway,
and I'm not sure if it is worth just going back and forth on dependency
versions.

Might be worth considering 0.7.1 or so, as that'll be easier for quite a few Linux distributions. But i wasn't complaining so much as giving someone a way to get GIMP Master compiled. If by 0.6.7 you meant 0.7.6, i'd suggest using that, as it's what several rolling/testing distributions have, but it's not a big deal.

Note for others reading this: editing the generated "configure" is fragile, of course - it'll get overwritten next time you run autogen.sh. This is what you probably want in this case, rather than mantaining your own separate versions of files stored in git, to avoid future problems.

Note that I originally chose this version 0.7.7 by looking at Debian Testing,

Yup. And it's not that unusual to have to build newer versions of things; sometimes i look at changelogs to decide whether to do that or to try & use the slightly older version, as here. Usually the Linux distribution i use -- Mageia Linux -- catches up with (or is sometimes ahead of) Debian Testing.

liam (slave ankh)

Liam Quin, https://www.holoweb.net/liam/cv/
Available for XML/Document/Information Architecture/
XSLT/XQuery/Web/Text Processing work and consulting.
Kevin Cozens
2018-08-02 18:04:09 UTC (3 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

On 2018-07-24 06:04 AM, Jehan Pagès via gimp-developer-list wrote:

On Sat, Jul 14, 2018 at 3:40 AM, Liam R E Quin wrote:

[snip]

For the record, I just checked current code and actual minimum dep (relatively to the functions I use from this lib) would be 0.6.7.

[snip]

Also this is development code. It is expected to get bumpy.

The addition of appstream-glib has been the biggest bump to date. When dependencies get bumped I just download, compile, and install the new version of the dependency. That hasn't worked with appsteram-glib.

This new dependency wants some support for RPM packages on a system that doesn't use RPM for package management. It also needed another dependency that I needed to compile but that needed yet another package. At that point I gave up trying to satisfy the need for appstream-glib.

What is appstream-glib and how is it going to be used in GIMP?

Cheers!

Kevin.

http://www.ve3syb.ca/               | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
                                     | that's why we're powerful"
Owner of Elecraft K2 #2172          |
#include      |             --Chris Hardwick
Jehan Pagès via gimp-developer-list
2018-08-03 10:01:54 UTC (3 months ago)

configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7

Hi!

On Thu, Aug 2, 2018 at 8:04 PM, Kevin Cozens wrote:

On 2018-07-24 06:04 AM, Jehan Pagès via gimp-developer-list wrote:

On Sat, Jul 14, 2018 at 3:40 AM, Liam R E Quin wrote:

[snip]

For the record, I just checked current code and actual minimum dep (relatively to the functions I use from this lib) would be 0.6.7.

[snip]

Also this is development code. It is expected to get bumpy.

The addition of appstream-glib has been the biggest bump to date. When dependencies get bumped I just download, compile, and install the new version of the dependency. That hasn't worked with appsteram-glib.

This new dependency wants some support for RPM packages on a system that doesn't use RPM for package management. It also needed another dependency that I needed to compile but that needed yet another package. At that point I gave up trying to satisfy the need for appstream-glib.

RPM libs and tools are available on most (if not all) distributions that I know of, even when based on other package systems (like .deb packages). :-) This being said, in appstream-glib, RPM support is an option. I'm not sure what it is used for, but I doubt we use anything related to this in GIMP. You should not try to make featureful builds of dependencies at the first attempt.

What is appstream-glib and how is it going to be used in GIMP?

This is a lib to process the AppStream metadata format. This is used for the new extension management system. I don't think that anyone will be ok to have builds without this feature, when it will be released, considering how important it will be, hence that's not an option. :-)

Note that I use the future because even though current dev code use this already, this will show its importance in more code to come. But it still has to be non-optional dep because we are no going to make our lives more difficult just for the sake of it.

I remind (just in case!) that master code is for development. It is certainly not advised for daily use, in particular. And we are not going to develop with outdated versions of libraries for instance (unless you want to see features be released with completely outdated code). So yes, we use recent versions (while still being reasonnable, hence the famous "at least available in Debian Testing" rule). A developer is expected to run such a modern OS for developer, not a LTS or other old distributions for "stable" systems.

Then there is the question of Windows or macOS. We hope we can help these libraries to become cross-platform soon (same as we helped libmypaint to be easily cross-compiled, as well as GExiv2, and many others… wasn't there libheif also recently?). That's what we do all the time. And hopefully this will happen again.
Now I am not saying it is impossible that we ever get back and use something else if it turns out really too complicated a task. But we need to at least try and go this way first. I currently see no reasons why it would turn out impossible to improve the library to be more cross-platform, as we did it for many others. That's what development is for.

Jehan

--
Cheers!

Kevin.

http://www.ve3syb.ca/ | "Nerds make the shiny things that https://www.patreon.com/KevinCozens | distract the mouth-breathers, and | that's why we're powerful" Owner of Elecraft K2 #2172 | #include | --Chris Hardwick _______________________________________________ gimp-developer-list mailing list
List address: gimp-developer-list@gnome.org List membership: https://mail.gnome.org/mailman /listinfo/gimp-developer-list
List archives: https://mail.gnome.org/archives/gimp-developer-list

ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot