Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

Why is the 0.44 version of poppler required?

This discussion is connected to the gimp-developer-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

3 of 3 messages available
Toggle history

Please log in to manage your subscriptions.

Why is the 0.44 version of poppler required? Kevin Cozens 07 Feb 17:03
  Why is the 0.44 version of poppler required? Jehan Pagès 09 Feb 18:02
   Why is the 0.44 version of poppler required? Kevin Cozens 11 Feb 16:00
Kevin Cozens
2018-02-07 17:03:45 UTC (8 months ago)

Why is the 0.44 version of poppler required?

Greetings.

The subject line of this message is the short version of this email.

The git master version of GIMP requires the 0.44 version of poppler. That version is not available for the 18.3 (latest) version of Linux Mint. I modified the configure.ac file to require the 0.41 version of poppler. I ran distclean and a full build of GIMP and had no compile errors. I have not seen any problems running GIMP with this older version of poppler.

Cheers!

Kevin.

http://www.ve3syb.ca/           |"Nerds make the shiny things that distract
Owner of Elecraft K2 #2172      | the mouth-breathers, and that's why we're
                                 | powerful!"
#include  |             --Chris Hardwick
Jehan Pagès
2018-02-09 18:02:44 UTC (8 months ago)

Why is the 0.44 version of poppler required?

Hello,

On Wed, Feb 7, 2018 at 6:03 PM, Kevin Cozens wrote:

Greetings.

The subject line of this message is the short version of this email.

A bit of git log searching gives the response to this:

commit b249a998aaa57fc85975dc5dd14088f125a82930 Author: Michael Natterer
Date: Mon Nov 7 16:00:52 2016 +0100

Bug 763214 - Wrong rendering of shadings in PDF imports...

...(in libpoppler -> requires a more recent version)

Require libpoppler >= 0.44.0 which contains a fix for this bug.

The git master version of GIMP requires the 0.44 version of poppler. That version is not available for the 18.3 (latest) version of Linux Mint. I

Note that git *master* is not supposed to follow whatever is in the stable distributions. We may have some advance, which is normal for a development version. If ever we limited ourselves to what is in any distribution *currently*, then *that* would be the start for problems.

In any case, as a general rule, it is better to have state-of-the art versions of everything since they are supposed to get better (but for exception and regression bugs).

modified the configure.ac file to require the 0.41 version of poppler. I ran distclean and a full build of GIMP and had no compile errors. I have not seen any problems running GIMP with this older version of poppler.

Yeah as the git message says, that's not a change of API or anything. So it would work. But then you may encounter bugs in rendering of shadings. Or not. We don't take the chance. :-)

Jehan

--
Cheers!

Kevin.

http://www.ve3syb.ca/ |"Nerds make the shiny things that distract Owner of Elecraft K2 #2172 | the mouth-breathers, and that's why we're | powerful!" #include | --Chris Hardwick _______________________________________________ gimp-developer-list mailing list
List address: gimp-developer-list@gnome.org List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list List archives: https://mail.gnome.org/archives/gimp-developer-list

ZeMarmot open animation film
http://film.zemarmot.net
Liberapay: https://liberapay.com/ZeMarmot/
Patreon: https://patreon.com/zemarmot
Tipeee: https://www.tipeee.com/zemarmot
Kevin Cozens
2018-02-11 16:00:43 UTC (8 months ago)

Why is the 0.44 version of poppler required?

On 2018-02-09 01:02 PM, Jehan Pagès wrote:

On Wed, Feb 7, 2018 at 6:03 PM, Kevin Cozens wrote:

Greetings.

The git master version of GIMP requires the 0.44 version of poppler. That version is not available for the 18.3 (latest) version of Linux Mint. I modified the configure.ac file to require the 0.41 version of poppler.

[snip]

So it would work. But then you may encounter bugs in rendering of shadings. Or not. We don't take the chance. :-)

Ok, thank you for that information. If that is the only problem I will stick with 0.41 for now. I have never needed to import PDF files in to GIMP.

Linux Mint 19 comes out around May. When it does I will revisit the poppler version I'm using. If I still need to build it the updated distro may (I hope) include the required versions of the other dependencies needed to build poppler 0.44.

Cheers!

Kevin.

http://www.ve3syb.ca/           |"Nerds make the shiny things that distract
Owner of Elecraft K2 #2172      | the mouth-breathers, and that's why we're
                                 | powerful!"
#include  |             --Chris Hardwick