Sign up now! · Forgot password?
RSS/Atom feed identi.ca Twitter

executable flag

This discussion is connected to the gimp-docs-list.gnome.org mailing list which is provided by the GIMP developers and not related to gimpusers.com.

This is a read-only list on gimpusers.com so this discussion thread is read-only, too.

4 of 4 messages available
Toggle history

Please log in to manage your subscriptions.

executable flag Kolbjørn Stuestøl 23 May 21:52
  executable flag Kolbjørn Stuestøl 24 May 00:37
   executable flag Vitaly Lomov 24 May 08:27
    executable flag Kolbjørn Stuestøl 24 May 09:31
Kolbjørn Stuestøl
2012-05-23 21:52:30 UTC (about 2 years ago)

executable flag

When doing "git commit" I get the error message "Translation files should not be executable. Please remove the flag and try to push again." And then some suggestions how to repair it. My question is: Where do I find this flag and what should it be set to? (By using a hex editor).

I am writing the po files using Notepad++ set to format UTF-8 without Byte Order Mark. My next step will be to try other formats, so perhaps my question is irrelevant? But I am curious about what happening.

BTW: The program tells me that an error has occurred, but the git log tells all is ok although the push stops with the mentioned error message. As far as I can see the log is wrong. But that's another question.
Kolbjoern

Kolbjørn Stuestøl
2012-05-24 00:37:49 UTC (about 2 years ago)

executable flag

Den 23.05.2012 23:52, skreiv Kolbjrn Stuestl:

When doing "git commit" I get the error message "Translation files should not be executable. Please remove the flag and try to push again." And then some suggestions how to repair it. My question is: Where do I find this flag and what should it be set to? (By using a hex editor).

I am writing the po files using Notepad++ set to format UTF-8 without Byte Order Mark. My next step will be to try other formats, so perhaps my question is irrelevant? But I am curious about what happening.

BTW: The program tells me that an error has occurred, but the git log tells all is ok although the push stops with the mentioned error message. As far as I can see the log is wrong. But that's another question.
Kolbjoern

According to the http://git.gnome.org/browse/gimp-help-2 the git log is right. The updates goes through but the program still tell me that the push failed. Ridicules.
Kolbjrn

_______________________________________________ gimp-docs-list mailing list
gimp-docs-list@gnome.org
https://mail.gnome.org/mailman/listinfo/gimp-docs-list

Kolbjrn Stuestl, Stuestl, 4580 Lyngdal
Telefon: (47) 38 34 78 62,  (47) 917 81 125
Stuestl heimesider: http://www.stuestoel.no
Sj ogs
Lyngdal hagelag: http://www.stuestoel.no/hagelag/hagelag.php
Mandal og Lister pyntegrntlag: http://www.mlpynt.no
GIMP p norsk: http://www.gimp.no

_______________________________________________
gimp-docs-list mailing list
gimp-docs-list@gnome.org
https://mail.gnome.org/mailman/listinfo/gimp-docs-list
Vitaly Lomov
2012-05-24 08:27:06 UTC (about 2 years ago)

executable flag

I got that error before. I think it's the way file is saved on Windows - it automatically acquires execution permissions if it's a new file and sometimes when existing file.
in Cygwin you just run
chmod 666 file_name
In git there is a way to check what the permissions were before and you can set them to original, as above, to avoid committing just the permission changes.

On Thu, May 24, 2012 at 1:37 AM, Kolbjørn Stuestøl wrote:

Den 23.05.2012 23:52, skreiv Kolbjørn Stuestøl:

When doing "git commit" I get the error message "Translation files should

not be executable. Please remove the flag and try to push again." And then some suggestions how to repair it.
My question is: Where do I find this flag and what should it be set to? (By using a hex editor).

I am writing the po files using Notepad++ set to format UTF-8 without Byte Order Mark. My next step will be to try other formats, so perhaps my question is irrelevant? But I am curious about what happening.

BTW: The program tells me that an error has occurred, but the git log tells all is ok although the push stops with the mentioned error message. As far as I can see the log is wrong. But that's another question. Kolbjoern

According to the http://git.gnome.org/browse/**gimp-help-2the git log is right. The updates goes through but the program still tell me that the push failed. Ridicules.
Kolbjørn

______________________________**_________________ gimp-docs-list mailing list
gimp-docs-list@gnome.org
https://mail.gnome.org/**mailman/listinfo/gimp-docs-**list

--
Kolbjørn Stuestøl, Stuestøl, 4580 Lyngdal Telefon: (47) 38 34 78 62, (47) 917 81 125 Stuestøl heimesider: http://www.stuestoel.no Sjå også
Lyngdal hagelag: http://www.stuestoel.no/**hagelag/hagelag.php Mandal og Lister pyntegrøntlag: http://www.mlpynt.no GIMP på norsk: http://www.gimp.no

______________________________**_________________ gimp-docs-list mailing list
gimp-docs-list@gnome.org
https://mail.gnome.org/**mailman/listinfo/gimp-docs-**list

Kolbjørn Stuestøl
2012-05-24 09:31:35 UTC (about 2 years ago)

executable flag

Den 24.05.2012 10:27, skreiv Vitaly Lomov:

I got that error before. I think it's the way file is saved on Windows - it automatically acquires execution permissions if it's a new file and sometimes when existing file.
in Cygwin you just run
chmod 666 file_name
In git there is a way to check what the permissions were before and you can set them to original, as above, to avoid committing just the permission changes.

Thank you a lot.

Kolbjoern